Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

HPILOCmdlets timouts

Highlighted
zsoltesz
Acclaimed Contributor

HPILOCmdlets timouts

If I try use any of the get-hpilo commnad, I get the next error:

Get-ErrorDetail : Error - 10.70.63.2 - ilocz262909wh.mol.sys.corp - Retrieving information from iLO.
Exception calling "UploadString" with "3" argument(s): "The operation has timed out"
At C:\Program Files\Hewlett-Packard\PowerShell\Modules\HPiLOCmdlets\HPiLOCmdlets.psm1:12758 char:21
+ throw $retobject.err
+ ~~~~~~~~~~~~~~~~~~~~
+CategoryInfo :OperationStopped: (Exception calli...has timed out"
:String) [], RuntimeException
+FullyQualifiedErrorId :Exception calling "UploadString" with "3" argument(s): "The operation has timed out"
At C:\Program Files\Hewlett-Packard\PowerShell\Modules\HPiLOCmdlets\HPiLOCmdlets.psm1:12858 char:17
+ Get-ErrorDetail $ErrorMsg
+ ~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException
+ FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Get-ErrorDetail

 

I have seen similar topics, but cannot find any solution.

The version is:

PS C:\Users\zsoltesz> Get-HPiLOModuleVersion


Name : HPiLOCmdlets
Path : C:\Program Files\Hewlett-Packard\PowerShell\Modules\HPiLOCmdlets\HPiLOCmdlets.psm1
Description : Scripting Tools for Windows PowerShell : iLO Cmdlets use the RIBCL interface to communicate to i
LO. These cmdlets can be used to configure and manage iLO on HPE ProLiant Gen7, Gen8 or Gen9 ser
vers.
GUID : 05545ade-5f25-4696-bfcc-e1d67fe32519
Version : 1.4.0.1
CurrentUICultureName : hu-HU
AvailableUICulture : {@{UICultureName=en-US; UICultureVersion=1.4.0.0}, @{UICultureName=zh-CN; UICultureVersion=1.3.0
.1}, @{UICultureName=ja-JP; UICultureVersion=1.3.0.1}}

9 REPLIES
CurtA
Acclaimed Contributor

Re: HPILOCmdlets timouts

I have had this issue crop up before.  The only way I've found to fix it is to perform a factory reset of the ilo.  Be careful, though.  If you have the LOM turned on, some models will reset that as well.  So, you'll not be able to remote in.  It's easy to fix if you're at the same location as the server but impossible if you're not.

GokulKS
Super Collector

Re: HPILOCmdlets timouts

Hi,

Probable reason could be that iLO server is not responding to our RIBCL HTTPS calls in the required timeout period (default - 60 seconds). We have the option to increase this timeout value from Set-HPiLOSessionTimeout cmdlet which will make all the iLO cmdlets to take the new value.

Before that you can try Find-HPiLO with iLO ip address to find out whether the iLO is reachable or not. This cmdlet also has timeout value where you can increase the value depending the response time.

Hope this helps.

Thanks,

Gokul

HPE PowerShell Team

 

zsoltesz
Acclaimed Contributor

Re: HPILOCmdlets timouts

Hi,

 

The Find-HPIlo works well. I increased the session timeot to 120 sec, but nothing hase changed. 

 

Zioli

 

GokulKS
Super Collector

Re: HPILOCmdlets timouts

Hi,

That's interesting Find-HPiLO works.

Can you share the results of this cmdlet for my reference.

The Session timeout cmdlet takes milliseconds as value hope you have converted while supplying the value to the cmdlet.

Set-HPiLOSessionTimeOut -TimeOut 120000

Please share your client environment details by executing below cmds and iLO FW details as well. 

(Get-WmiObject Win32_OperatingSystem).Name

$PSVersionTable

I hope all the necessary ports are enabled from client to iLO server like 443 and 80 for normal communication.

Thanks,

Gokul

zsoltesz
Acclaimed Contributor

Re: HPILOCmdlets timouts

Hi,

 

PS C:\Users\zsoltesz> $psversiontable

Name Value
---- -----
PSVersion 5.1.14409.1005
PSEdition Desktop
PSCompatibleVersions {1.0, 2.0, 3.0, 4.0...}
BuildVersion 10.0.14409.1005
CLRVersion 4.0.30319.42000
WSManStackVersion 3.0
PSRemotingProtocolVersion 2.3
SerializationVersion 1.1.0.1

PS C:\Users\zsoltesz> (Get-WmiObject Win32_OperatingSystem).Name
Microsoft Windows 7 Professional |C:\WINDOWS|\Device\Harddisk0\Partition2

 

I can connect to the iLO with the browseres, so I think the ports are ok.

 

There are no traces in the iLo log, when I try to use the get-hpilo* commands. There is no connection at all.

The iLO is ILO4 ver 2.50 and 2.40

 

Regards,

Zoli

GokulKS
Super Collector

Re: HPILOCmdlets timouts

Hi,

Can you share your mail id i can connect to you offline as this issue seems to be an one-off case and may be related to environment.

Thanks,

Gokul

EMAIL ID: Private Info Erased

 

zsoltesz
Acclaimed Contributor

Re: HPILOCmdlets timouts

Hi,

My address is Private Info Erased

 

Thanks,

Zoli

GokulKS
Super Collector

Re: HPILOCmdlets timouts

The issue got resolved after some changes happened on LAN side.

Confirmation from the customer.

 

Thanks,

Gokul

Tyronis
Acclaimed Contributor

Re: HPILOCmdlets timouts

Hi,

Could you please share the solution. I've got the same issue on a W2K12 R2 server when using any HP iLO cmlet (except for the find-hpilo cmdlet)

Thanks in advance.

Tryonis

//Add this to "OnDomLoad" event