Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel

HP-ILO problems - SLES 9 (i586) - Error loading hpilo module

SOLVED
Go to solution
Highlighted
damade
Valued Contributor.

HP-ILO problems - SLES 9 (i586) - Error loading hpilo module

Hi Everyone !!!

 

I am having the following issue with ILO and SLES 9.

 

OS version:

2.6.5-7.244-bigsmp #1 SMP 2005 i686 i686 i386 GNU/Linux

SUSE LINUX Enterprise Server 9 (i586)
VERSION = 9
PATCHLEVEL = 3

 

ILO version:

rpm -qa |grep ilo
hp-ilo-8.2.0-236.sles9

 

 

When trying to start the iLO channel driver 

/etc/init.d/hp-ilo start
  Starting hp-ilo:     hp-ilo: Error loading hpilo module

 

The /var/log/messages says:

 kernel: hpilo: module not supported by Novell, setting U taint flag.
 kernel: hpilo: Unknown symbol ioread32
 kernel: hpilo: Unknown symbol iowrite32
 kernel: hpilo: Unknown symbol pci_iomap
 kernel: hpilo: Unknown symbol kzalloc
 kernel: hpilo: Unknown symbol iowrite8
 kernel: hpilo: Unknown symbol pci_iounmap

 

Any Ideas ?

Thanks

2 REPLIES
Matti_Kurkela
Super Contributor.

Re: HP-ILO problems - SLES 9 (i586) - Error loading hpilo module

You're running SLES 9 SP3, which was released in December of 2005, so it's rather old.

 

The "Unknown symbol" messages look like the hp-ilo driver depends on some features added by a kernel patch you don't have. Perhaps the hp-ilo 8.2.0 requires SLES 9 SP4, although neither the release notes nor the installation instructions say that explicitly. You might want to try an older version of the hp-ilo driver.

 

Version 8.1.0 for 32-bit SLES 9:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=5351&prodSeriesId=1121516&prodNameId=3288134&swEnvOID=1110&swLang=8&taskId=135&swItem=MTX-0308640af52943949fd04db551&mode=3

 

Version 8.0.0 for 32-bit SLES 9:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=5351&prodSeriesId=1121516&prodNameId=3288134&swEnvOID=1110&swLang=8&taskId=135&swItem=MTX-de5fe03677764290bf79ac8650&mode=3

MK
damade
Valued Contributor.
Solution

Re: HP-ILO problems - SLES 9 (i586) - Error loading hpilo module

Thanks Matti.

Downgrading to version 8.0 SOLVE THE ISSUE.