The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Remote Lights-Out Mgmt (iLO 2, iLO, RILOE II) Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Determine the ILO2 Management Controller Driver Version

Highlighted
Ray Bell
Occasional Contributor

Determine the ILO2 Management Controller Driver Version

I receieved the following alert about my DL380 servers and I had two went down recently and was sure why:

HP ProLiant DL380 G5 Server series
• » Advisory: (Revision) Integrated Lights-Out 2 (iLO 2) Firmware Version 1.70 (Or Earlier) And iLO 2 Management Controller Driver Version 1.9.0 Or 1.11 - ProLiant Server May Unexpectedly Reboot And Display Event ID 57 Error Messages (c01802766)

So the firmware version I have is 1.61 and I need to determine the management controller driver version. If this is th problem then I will have to correct it and have never update firmware to a DL380 server but we have 30 servers.
8 REPLIES

Re: Determine the ILO2 Management Controller Driver Version

Driver name = hpqilo2.sys. Search on that file, or you can use SIM and check software versions.

Current version I think is 1.15. I'm using 1.12 with no issues. 1.12 does not gripe about wanting a reboot when you install it, 1.15 does.

Latest ILO2 FW = 1.81.
Ray Bell
Occasional Contributor

Re: Determine the ILO2 Management Controller Driver Version

Base on the error they are saying you need to have the newer version in or the server will reboot. Maybe I'm missing something but look like they are saying that you need at least version 1.9.0 or higher for the driver.

Re: Determine the ILO2 Management Controller Driver Version

Ray,

Yeah, I think you mis-read something. I have pasted this in directly from the advisory:

RESOLUTION
In order to prevent unexpected server reboots, upgrade to both of the following:

â ¢Integrated Lights-Out 2 (iLO 2) Firmware Version 1.78 (or later)
â ¢iLO 2 Management Controller Driver Version 1.11.2.0 (or later)

And I had to hit about 60 servers myself.

The HP FW CD 8.70 includes ILO2 FW 1.81, and the 8.30 PSP (unless there is a newer one) has either 1.12.0.0 or 1.15.0.0 (I'd have to check).
Ray Bell
Occasional Contributor

Re: Determine the ILO2 Management Controller Driver Version

Look like I will have to download the software from HP site and install this on all 30 of my servers. Have any of your server already reboot unexpected? Two of my servers reboot and I have no idea why so this is why.

Re: Determine the ILO2 Management Controller Driver Version

yeah, I had a couple go on me. No issues since the updates.

If you use the Windows online ILO firmware package and the 1.12 driver, you can do the updates without needing reboots.
Ray Bell
Occasional Contributor

Re: Determine the ILO2 Management Controller Driver Version

I'm using Red Hat 5 so this would not work for me using the windows version correct? Also did you download your fix or you use the cd?

Re: Determine the ILO2 Management Controller Driver Version

If you read the list of affected operating systems at the bottom of the advisory, I only see various versions of Windows listed - no RHEL. So I'd probably start looking elsewhere for your reboot issues - but starting with the log files all the same.

Having said that, I'd still advise upgrading - but I'd be looking elsewhere for your issues now... unless this bug DOES in fact apply to RHEL and HP just hasn't updated that part of the advisory yet (HP?).
Ray Bell
Occasional Contributor

Re: Determine the ILO2 Management Controller Driver Version

The information points me in the right direction.

Thanks
//Add this to "OnDomLoad" event