Project and Portfolio Management Practitioners Forum
cancel

we get error when run kStart.sh

Highlighted
RsmARSLN
Regular Contributor.

we get error when run kStart.sh

Hi,

 

When we started ppm, we get following error message . I set as HPPPM on  'com.kintana.core.server.KINTANA_SERVER_NAME' parameter.

 

 

STATUS server:main:(?:?):2016/05/03-21:30:43.831 EEST: Logging reconfiguration complete
STATUS server:main:(ServerStartupSanity.java:88):2016/05/03-21:30:43.835 EEST: Running pre-startup checks for node HPPPM in standalone mode
ERROR server:main:(ServerStartupSanity.java:88):2016/05/03-21:30:43.835 EEST: Node HPPPM cannot be found in server.conf
ERROR server:main:(ServerStartupSanity.java:88):2016/05/03-21:30:43.847 EEST: PPM will not start
STATUS server:main:(?:?):2016/05/03-21:41:48.967 EEST: Logging reconfiguration complete
STATUS server:main:(ServerStartupSanity.java:88):2016/05/03-21:41:48.972 EEST: Running pre-startup checks for node HPPPM in standalone mode
ERROR server:main:(ServerStartupSanity.java:88):2016/05/03-21:41:48.972 EEST: Node HPPPM cannot be found in server.conf
ERROR server:main:(ServerStartupSanity.java:88):2016/05/03-21:41:48.983 EEST: PPM will not start

 

Thanks

 

8 REPLIES
TurboMan
Honored Contributor.

Re: we get error when run kStart.sh

Hi,

If this is ok for you,  We need to see the server.config file, sounds like something wrong in config file.

RsmARSLN
Regular Contributor.

Re: we get error when run kStart.sh

Thank you TurboMan. I uploaded server.conf file. In fact we migrated ppm from window to linux red hat. we reconfigured server.conf and linux enviorement settings. Then when we start.sh, ocure this error.

 

Thanks.

RsmARSLN
Regular Contributor.

Re: we get error when run kStart.sh

Also i attached kSupport file.

Erik Cole
Acclaimed Contributor.

Re: we get error when run kStart.sh

Hi...couple of things:

(1) are you running kStart with the name parameter? like sh ./kStart.sh -name HPPPM

(2) does kUpdateHtml.sh run sucessfully?

(3) are there any directories other than HPPPM in your $PPM_HOME/server directory?

RsmARSLN
Regular Contributor.

Re: we get error when run kStart.sh

Hi Erik,

 

We runnig kStart.sh whit -name parameter but occured same error. kUpdateHtml.sh run succesfully, there is no other folder in Server folder. We think there is wrong paremter in server.conf file.

 

Thanks. 

AlexSavencu
Acclaimed Contributor.

Re: we get error when run kStart.sh

Hi,

this error occurs when there is a mismatch between KINTANA_SERVER_NAME configured in server.conf and the directory name under $PPM_HOME/server.

You may paste here the output of kUpdateHtml.sh and the contents of the $PPM_HOME/server directory. It should be pretty obvious after this.

 

cheers

alex


--remember to kudos people who helped solve your problem
Erik Cole
Acclaimed Contributor.

Re: we get error when run kStart.sh

This is a long shot, but you might try two things:

(1) completely delete all the stuff out of the bottom of your server.conf that pertains to the second HPPPM2 node, even though you have it commented out

(2) if you're using any Windows utility (notepad, wordpad, etc) to edit server.conf then after you save it to your Linux server run the dos2unix utility on it to remove any potential hidden Windows characters that it could choke on

Aurobinda
Respected Contributor.

Re: we get error when run kStart.sh

HI,

Would you please try the below steps:

1. stop ppm services.

2. In windows generally we use services. (please try to remove and reinstall services) and then try to start. If it doesn't work, please try 3rd step as well.

3. After stopping ppm services(PPM nodes), try sh kConfig.sh and follow the on screen instructions. you might not need to change anything but just complete the full steps once and then try to start ppm.

4. If still it didn't work, then need to analyze the server.conf parameters specific to platform, also need to check the logs from command prompt at the time of starting.