Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

the attribute "Newest Notice" not displayed as a choice in the available columns.

SOLVED
Go to solution
Highlighted
davensky
Occasional Contributor

the attribute "Newest Notice" not displayed as a choice in the available columns.

Hi

 

Situation:

There are two different Request types. The first one is for Defect and the second one for Enhancement.  When configuring an HP delivered portlet(Request lists) one can configure the portlet for each request types separately or together. 

 

Problem: 

When configuring the said portlet ONLY for Defect or Enhancement request types using the advanced filter, one can see the field " Newest Notice" in the available columns. But, If one wants to configure the portlet for BOTH request types, the field is not displayed as one of the available columns.

 

Question:

 

Is it possible to make the said field available for selection when both request types are selected in the field "Request type" ? 

 

Thank you

 

Regards

 

  

5 REPLIES
dirkf
Honored Contributor

Re: the attribute "Newest Notice" not displayed as a choice in the available columns.

Hi davensky,

 

the advanced search available columns will show all fields that have the same token in both request types. I believe that the latest notice should be a field visible in both request types but I haven't checked, I'd have to do that.

Check if the field has the same field token, is present in both Request Types and available in the display columns on again both RTs.

 

I wrote a doc some time ago about the advanced search and the available columns there in multiple request types. Don't have the ID handy right now but it should be visible on SSO.

 

Let's have more infos if you need more from us.

 

Best regards,

Dirk

davensky
Occasional Contributor

Re: the attribute "Newest Notice" not displayed as a choice in the available columns.

Hi Dirk,

 

The field is not a custom filed. It is a SYSTEM field.  As I have not defined it, I had no need to give a token to the field. Therefore, the issue has less to do with TOKEN but something else. The name of the field in the german version is called "Neuste Notiz"

 

Thanks

Davensky

 

 

 

Utkarsh_Mishra
Honored Contributor

Re: the attribute "Newest Notice" not displayed as a choice in the available columns.

Hi Davensky,

 

Try to make all the attribute and "Name/Token" of "Newest Notice" field same in both the requests.

 

As mentioned by "", In case if you are selecting two request type then the Advance search only shows the common ones.

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
dirkf
Honored Contributor
Solution

Re: the attribute "Newest Notice" not displayed as a choice in the available columns.

HI David,

 

I was able to easily reprooduce the issue in a request list portlet on 7.57 with two ootb-portlets.

The problem is that the 'most recent note' is not a field as we know it from Workbench. When using the preferences to set up the portlet, I can see the 'most recent note' for 'Bug' (outofthebox Request Type) as well as for 'Enhancement' but not for both.

 

There WAS a defect for this already logged for 7.1 which was fixed, but this seems to be a repeat of that issue or a config change I'm not aware about.

What I find however is that if you DO NOT use Advanced Filter to add the fields to Dashboard, the most recent note is shown. So remove all Request Types from the portlet. Then save. You will then be shown the (empty) Request List Portlet preferences. Now check the available columns – the most recent notes are there (common out of the box). Move them to display columns. Now open the request type button (automcomplete) right of the field and left of advanced filter. Choose Defect and Enhancement. Most recent note is still shown.

 

Does this help?

 

Best regards,

Dirk

davensky
Occasional Contributor

Re: the attribute "Newest Notice" not displayed as a choice in the available columns.

 

Hi Dirk,

 

Thank you so much for the workaround. Your reply has helped me! I could reproduce it after your instructions

 

Regards

 

 

//Add this to "OnDomLoad" event