Project and Portfolio Management Practitioners Forum
cancel

"Command Execution Error" message when trying to migrate using Object Types

SOLVED
Go to solution
Highlighted
JHarris941
Super Contributor.

"Command Execution Error" message when trying to migrate using Object Types

Hello All,

 

We just started to receive this error message when we try to migrate code in the workbench:

 

 

java.lang.NullPointerException
at com.kintana.core.util.LogFileWriter.flush(LogFileWriter.java:151)
at com.kintana.core.util.MultiWriter.flush(MultiWriter.java:161)
at com.kintana.core.util.HtmlFilterWriter.flush(HtmlFilterWriter.java:20

 

This happen before even a log is produced so I assume its something PPM does before migrations. Has anyone experienced this before? I included a screenshot of the package line status as well.

 

Thanks,

Jajcen

5 REPLIES
Utkarsh_Mishra
Acclaimed Contributor.

Re: "Command Execution Error" message when trying to migrate using Object Types

Every OS has a limit of number of sub directories within any directory, so quite possible that your log directory limit is reached. Try this

 

  • Delete some of the old request/package/report directory within <PPM_ROOT>/logs

 

If still issue persitis then check whether your have enough disk space for PPM application on your server.

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
JHarris941
Super Contributor.

Re: "Command Execution Error" message when trying to migrate using Object Types

hey 

Utkarsh_Mishra
Acclaimed Contributor.

Re: "Command Execution Error" message when trying to migrate using Object Types

It is getting error when closing the File Stream (flush); can you try again by shortening the name of object.

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
JHarris941
Super Contributor.
Solution

Re: "Command Execution Error" message when trying to migrate using Object Types

Thanks Utkarsh for your help..from your suggestion we were able to determine the issue.

 

Within our PPM_HOME/logs directory there were some directories owned by root.  They should have been owned  by our application user.  These directories
are the REQ_% and PKG_% ones.

The last modified date on all of them is July 11th.

We think PPM was restarted by someone as root on that day.

When our weekly maintenance ran the next day, the problem stopped expanding because PPM was correctly started by our application user.

So now in PPM when those affected directories are accessed we get execution errors. (The ones owned by root.)

 

Thanks again for your help.

 

Jajcen

Utkarsh_Mishra
Acclaimed Contributor.

Re: "Command Execution Error" message when trying to migrate using Object Types

Great, good to know this :)

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)