Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

not able to logon(if authentication mode is ldap) after deployment of sp4

SOLVED
Go to solution
Highlighted
happa
Collector

not able to logon(if authentication mode is ldap) after deployment of sp4

Hello,

After deployment of service pack 4, users who has the authentication mode of LDAP are not able to logon.

Its showing the below error message:

" User not present in LDAP server. Please contact your LDAP server administrator. (KNTA-10409) ".

After we deployed sp3, we need not change any parameter for ldap and users were able to logon properly.

But after sp4 is deployed, there is some issue with LDAP authentication.

If the authentication mode is 'PPM', then there is no problem with the logon. If it is 'LDAP', then we are not able to logon.

Could you please help us if we need to change any parameter in ldapAttribute.conf.

Thanks in advance.

Best Regards,
Sanjeeban.

6 REPLIES
AlexSavencu
Honored Contributor

Re: not able to logon(if authentication mode is ldap) after deployment of sp4

Hi,

 

my strong suggestion is o check if the parameters in ldapAttribute.conf are correct - we have encountered situations where the upgrade deleted most of the parameters in this file.

 

cheers

alex


--remember to kudos people who helped solve your problem
happa
Collector

Re: not able to logon(if authentication mode is ldap) after deployment of sp4

Hi Alex,

 

First of all, thanks a lot for your quick reply.

 

I have checked the new ldapAtrribute.conf file generated after deployment of sp4.

 

Few parameters like ldap_user_id,ldap_logon_id has been changed to 'sAMAccountName' which was 'uid' in sp3.

 

Some other parameters have also changed.

 

So I replaced the new ldapAtrribute.conf file with the old one(sp3)cand tested.

 

After that, it was showing the same error. So, now I have again kept the new one in server.

 

I have 2 doubts.

 

1.Should I just modify the parameters in the new ldapAttribute.conf as those parameters in the old file?

 

2.Along with the ldapAttribute.conf file do I need to modify the ' ldapAttribute_AD.conf ', ' ldapAttribute_NDS.conf ', ' ldapAttribute_Netscape.conf ' files also?

 

I am attaching both the old and new ldapAtrribute.conf file.

 

Please let me know if I need any other things to modify.

 

Thanks in advance for your reply.

 

Best Regards,

Sanjeeban.

AlexSavencu
Honored Contributor

Re: not able to logon(if authentication mode is ldap) after deployment of sp4

Hi,

 

regarding your doubts:

1. yes.

2. quoting from the documentation:

 

Copy the appropriate LdapAttribute_<Vendor_Name>.conf file and
overwrite the LdapAttribute.conf file in the same directory.
If you are using Microsoft Active Directory, replace the
LdapAttribute.conf file with the <PPM_Home>/integration/ldap/
LdapAttribute_AD.conf file.
If you are using a Sun Java System Active Server Pages LDAP server,
replace the LdapAttribute.conf file with the <PPM_Home>/
integration/ldap/LdapAttribute_Netscape.conf file.

 

It is always good to check the product documentation before posting here.

 

cheers

alex


--remember to kudos people who helped solve your problem
Jim Esler
Honored Contributor
Solution

Re: not able to logon(if authentication mode is ldap) after deployment of sp4

When you change ldapAttribute.conf, you will need to stop and restart PPM to have the changes take effect.

happa
Collector

Re: not able to logon(if authentication mode is ldap) after deployment of sp4

Hi Alex and Jim,

 

LDAP authentication issue is resolved after replacing the ldapAttribute.conf file with the old one.

 

Thanks a lot for helping.

 

Best Regards,

Sanjeeban.

Acamargo
Regular Collector

Re: not able to logon(if authentication mode is ldap) after deployment of sp4

Sanjeeban.

His problem was solved. After you returned the file for version 8.0?

//Add this to "OnDomLoad" event