Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

ldap integration fails - ppm 7.5

SOLVED
Go to solution
Highlighted
firess
Occasional Contributor

ldap integration fails - ppm 7.5

i've set up ppm to authenticate users with ldap,but authentication is failing with the error message below.
java.lang.NoClassDefFoundError: com.sun.net.ssl.internal.ssl.Provider

i can login to the ldap server from the ppm server so i'm not sure where i'm getting it wrong.
thankx
8 REPLIES
Alan Delimon
Regular Collector

Re: ldap integration fails - ppm 7.5

It looks like it is trying to use SSL to get to your LDAP server.

Do you need this setup? If so you'll need to configure the SSL.

If not, you can just turn off SSL by adding a port number to LDAP_URL, and setting LDAP_SSL_PORT to blank. In server.conf this is spelled out:
#
# If the LDAP server is SSL enabled then this should be set to the
# SSL port of the LDAP server (which is usually 636). This port will be
# used to carry out all secure transactions. If this field is not set, then
# all transactions will be carried out over the port specified in the param
# LDAP_URL
#
com.kintana.core.server.LDAP_SSL_PORT=
firess
Occasional Contributor

Re: ldap integration fails - ppm 7.5

I have tried without secure ldap ,but it still fails with the same error.i have tested ldap connection from the ppm server using a java ldap test tool,this connects immediately.it seems to me ppm has an issue,i'll appreciate ur help.

thanks
Erik Cole
Honored Contributor
Solution

Re: ldap integration fails - ppm 7.5

What PPM/Server OS/JDK versions? Seems like you're missing a jar file in JAVA_HOME...?
firess
Occasional Contributor

Re: ldap integration fails - ppm 7.5

Thanks, it was a java problem.i was using the ibm version of java that comes with SLES10 but i realized that was 1.5.0, i have installed 1.5 with update 16 and it works.
AndreaB_1
Occasional Advisor

Re: ldap integration fails - ppm 7.5

HI,
I'm running to the same error after upgrading to 7.5
Our Java is the below version running on AIX.

java -version
java version "1.5.0"
Java(TM) 2 Runtime Environment, Standard Edition (build pap32devifx-20080811c (SR8a))
IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 AIX ppc-32 j9vmap3223ifx-20080811 (JIT enabled)
J9VM - 20080809_21892_bHdSMr
JIT - 20080620_1845_r8
GC - 200806_19)
JCL - 20080811b
Could you please let me know where you got the update 16 from?


jerome.vovard
Regular Collector

Re: ldap integration fails - ppm 7.5

Hi All,
I'm looking for the IBM JDK in 32bits.
Could you tell me where I could find it?
I'm using the IBM JDK in 64bits and I have some issues using the WebServices Toolkit.
Everything works correctly except the webservices.
So I want to test with a 32bits IBM JDK.
Regards,
Jerome VOVARD
Erik Cole
Honored Contributor

Re: ldap integration fails - ppm 7.5

jerome.vovard
Regular Collector

Re: ldap integration fails - ppm 7.5

Thank you Mr Cole,
this URL link 's gonna help me.
Regards,
//Add this to "OnDomLoad" event