Project and Portfolio Management Practitioners Forum
cancel

ksc_set REMOTE_SERVER_TYPE=grep: server.conf: No such file or directory

Highlighted
jerome.vovard
Super Contributor.

ksc_set REMOTE_SERVER_TYPE=grep: server.conf: No such file or directory

I want to create a package so I set an environment. But I got this error while trying to get the list of the request type under the workflow field (i choose the PPM workflow Migrator as object type).
I attached the error file.
Any help,
If you need more details. tell me.
4 REPLIES
Darshan Bavisi
Outstanding Contributor.

Re: ksc_set REMOTE_SERVER_TYPE=grep: server.conf: No such file or directory

Hi Jerome,

There's some possible error in the command,

"grep SERVER_TYPE_CODE server.conf | cut -c42-; echo KSC_EXIT_STATUS $?"

If the command is fine then try removing '-login-2.05b' from the shell prompt and leave the shell prompt as only '$'. This is just to test and make sure that the shell prompt parsing is not causing this issue in PPM.
jerome.vovard
Super Contributor.

Re: ksc_set REMOTE_SERVER_TYPE=grep: server.conf: No such file or directory

Thank you for your update Darshan,
But I have the same shell prompt to my own VmWare and PPM dpackage works correctly on it.
I repeat that I have this error on the customer site but i can't reproduce it on my VmWare image. I tried to compare the both server (customer one and mine) And I found some differences in the following registry keys:
HKEY_LOCAL_MACHINE ï   SOFTWARE ï   Microsoft ï   TelnetServer ï   1.0.etc...
I found this information into the document:ServiceWareMercury_39902_CPT39903_doc.doc.

I'm gonna create a movie with webexr recorde and I 'll attach it here.
Regards,
Torsten Neumann
Trusted Contributor.

Re: ksc_set REMOTE_SERVER_TYPE=grep: server.conf: No such file or directory

Have you tried a different path?

Are you sure the system correctly changes the directory to C:\environments\dev? Have you tried using forward slashes?

Try to insert a "pwd" command before the line with the "grep". I assume you are in the wrong directory.

Cheers,
Torsten
Kintana strikes back... ;-)
jerome.vovard
Super Contributor.

Re: ksc_set REMOTE_SERVER_TYPE=grep: server.conf: No such file or directory

Hi All,

In fact, the issue as due to the fact that a old version of the Workbench already existed to the machine. I mean, I opened the workbench to a new brand machine, and it worked, no error.

REgards,