The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

ksc_local_exec sleep command works in DEV but not in QA?

Highlighted
Kevin Marks
Occasional Contributor

ksc_local_exec sleep command works in DEV but not in QA?

We are using an execution step with a sleep command to slow down processing of multiple commands.
This works perfectly in our DEV environment but then fails in our QA environment, Both DEV and QA have the same exact set-up of the workflow and step source.

Would anyone have any idea why this works in one environment and not another?
TIA for any suggestions.

The command is ...
ksc_local_exec sleep .01s
3 REPLIES
Tim Brandish
Frequent Visitor

Re: ksc_local_exec sleep command works in DEV but not in QA?

do you have the sleep shell script in your QA environment? You'd need to copy the script there from Dev. Also, make sure the application user (itguser) has permission to execute it.
Kevin Marks
Occasional Contributor

Re: ksc_local_exec sleep command works in DEV but not in QA?

Tim,
thanks for the help, we looked at both suggestions and they were both fine.
So instead of the sleep command we used
ksc_local_exec ping 127.0.0.1 -n 5
to slow the system down.
And this did exaclty what we needed it to.

thanks
Kevin
Kevin Marks
Occasional Contributor

Re: ksc_local_exec sleep command works in DEV but not in QA?

used
ksc_local_exec ping 127.0.0.1 -n 5
instead of sleep command
//Add this to "OnDomLoad" event