Project and Portfolio Management Practitioners Forum
cancel

jump/receive steps slow

Highlighted
Daniel U
Frequent Contributor.

jump/receive steps slow

We are having performance issues with the jump/receive steps. It takes at least 1 minute to perform a jump/receive. This is causing issues for our workflow where the request workflow can lag far behind the package workflow, resulting in some 'stuck' workflows. This is all due to the time-lag for the jump/receive steps. Is there some way to decrease this time- perhaps through a server.conf parameter?

Thanks in advance for any suggestions
2 REPLIES
Cris Robin
Respected Contributor.

Re: jump/receive steps slow

We experienced this problem also in another field.
The only way I found to override this problem is to check, with timeout, in several key steps, if the request in the right status (workflow step) or not.

Hope it help

Sagi
Marlene Mazzeo
Super Contributor.

Re: jump/receive steps slow

We had the same issue and found it was related to a recommended setting from HP/Oracle for Oracle 10.2.0.2:
----------------------------
Run the following command from an SQL*Plus session as sysdba.

For details, refer to Oracle bug
number 5455729.

alter system set "_optimizer_connect_by_c
ost_based"=false
-----------------------------
When we switched it back to true, the performance issues were resolved. We kept it this way for a while, and did not see the issue related to the bug.

The bug mentioned above is resolved in 10.2.0.3 with a patch.

We ended up upgrading our database to 10.2.0.3 and applying all recommended patches, along with the one that resolved the above bug.

We also had severe performance problems when recompiling our token-based security in our workflows, and switching that one flag from false to true only slightly helped, and that was reason for our upgrade to 10.2.0.3 versus staying on 10.2.0.2.