Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Wrong date in PPM emailing

Highlighted
sucec
Occasional Contributor

Wrong date in PPM emailing

Hi,
I face an issue with the date of mails send by PPM (notifications send by the workflow).
Today (Feb. 10th), I get some notifications with March, 10th as date.
I also see some mails send on Feb, 6th but with January, 6th as date.
Has someone already faced such problem or maybe that someone has an idea from where it comes from?
Thanks
12 REPLIES
Jason Nichols K
Honored Contributor

Re: Wrong date in PPM emailing

Brette,

Do your notifications use a Token for the dates? That would be the first place I look.

Jason
sucec
Occasional Contributor

Re: Wrong date in PPM emailing

Hi Jason,
No I do not use any token for the dates.
I use the standard notification properties.
For example when a request is created, the system send a notification to a set of users (token defined).
Jason Nichols K
Honored Contributor

Re: Wrong date in PPM emailing

The dates the emails are sent should be coming from the system of the server that PPM is installed on. Have there been any changes to that server recently?
sucec
Occasional Contributor

Re: Wrong date in PPM emailing

Among my IT... no
I'm looking for PPM variables regarding dates, but found nothing for the moment.
Jim Esler
Honored Contributor

Re: Wrong date in PPM emailing

If you are referring to a date in the email header, this is set by the servers processing the email as has already been mentioned. Verify the date settings on the servers handling the email, in particular the ones running PPM, the one hosting the post office and your PC.

I inadvertently set my PC one month ahead one time when I just wanted to look at the calendar. The change wreaked havoc with several applications, including connecting to my ISP.
sucec
Occasional Contributor

Re: Wrong date in PPM emailing

Thanks I'll ask for verifying.
Sergi2304
Occasional Contributor

Re: Wrong date in PPM emailing

Hi sucec,

I'm experiencing the same problem: notifications sending date have (sometimes) incorrect months.

I ask for the dates set on each server and everything was correct.

Did you find the solution to this problem or where are email dates set?

Thanks,
sucec
Occasional Contributor

Re: Wrong date in PPM emailing

Hi,
Sorry for this late answer.
Unfortunately I have not yet solved the problem.
I raised a new CR against HP support.
For the moment, I didn't see anything wrong in PPM server traces.
Sergi2304
Occasional Contributor

Re: Wrong date in PPM emailing

Hi sucec,

Are you still trying to resolve this problem?

I have been talking with HP Support and it seems to be a problem with thee configuration of JVM.

If you had your region and language different from english sometimes the JVM doesn't understand the month of some dates.

They tell me to use this configuration at server.conf and run PPM as a Service:
com.kintana.core.server.JVM_OPTIONS=-Duser.language=en -Duser.region=US

Now I'm trying to make some tests to know if that's the solution. For the moment it works fine but I'm not able to reproduce the error so I cannot be sure 100%.

Do you know how to reproduce the error?

Thanks very much,

Sergi Puigventós
sucec
Occasional Contributor

Re: Wrong date in PPM emailing

Thanks Sergi.
They didn't provide me any answer yet.
I'll try with your solution and let you know.
Thanks again.
sucec
Occasional Contributor

Re: Wrong date in PPM emailing

Hi Sergi,
I implemented this solution in Prod (PPM 7.1) and it works.
Unfortunately we are planning to upgrade in 7.5 in few days and it does not work...
Thanks to have shared your solution.
Sergi2304
Occasional Contributor

Re: Wrong date in PPM emailing

You're welcome,

I'm having no problems with the solution too.

The problem in 7.5 could be also JVM configuration. It's a question of finding the correct parameters to configure it.

Au revoir et merci beaucoup,

Sergi Puigventós
//Add this to "OnDomLoad" event