Project and Portfolio Management Practitioners Forum
cancel

Workflow Isuue

Highlighted
Pachi
Super Contributor.

Workflow Isuue

Hi,

 

We have a defect request type, when we create an ITG with this request type it picks up bug defect qorkflow and not defect request workflow,how to get this corrected.

 

Regards,

Pachi

Regards,
Pachi
13 REPLIES
Raj Ghimire
Outstanding Contributor.

Re: Workflow Isuue

First thing to look would be whether or not the Workflow that you are trying to use is "Enabled".

 

If it is, simply create a "Set Workflow" Rule in the Reuquest type for "Apply on Creation" event to pick the Workflow that you are tyring to use.  That should set things straight.

 

Thanks.

-Raj

Pachi
Super Contributor.

Re: Workflow Isuue

I quit didn't get u:(

 

If it is, simply create a "Set Workflow" Rule in the Reuquest type for "Apply on Creation" event to pick the Workflow that you are tyring to use.  That should set things straight.??

 

Regards,
Pachi
Pachi
Super Contributor.

Re: Workflow Isuue

I have this as suggested, but still its pointing to old workflow.Please find the screen shot enclosed.

 

Regards,

Pachi

Regards,
Pachi
Raj Ghimire
Outstanding Contributor.

Re: Workflow Isuue

Please double check if your "Defect Request Workflow" is Disabled.

When you create a New WF, generally by default, it is Disabled and you have to Enable it manually before you can use it. 

 

So, in the "Workflow" tab of the workflow, "Enabled" value needs to be "Yes" to make sure the request can pick that WF, if it is not enabled, it will always pick up Default WF defined in the system.

 

-Raj

 

Pachi
Super Contributor.

Re: Workflow Isuue

I can confirm you that it is enabled,

Regards,
Pachi
Raj Ghimire
Outstanding Contributor.

Re: Workflow Isuue

Sorry I could not think of any other thing right now..

I would think, as long as the desired Workflow as well as the Request Rule to set that workflow at Creation are Enabled, this should have been one of the simplest things between Request and WF relationship. ..But it seems we are possibly missing somethign else here. So, it would be wise to contact product Support so that they can possibly Remote in and check your Configuration quickly without wasting too much time.

 

Thanks.

-Raj

Raj Ghimire
Outstanding Contributor.

Re: Workflow Isuue

One more thing you can try.

 

- Delete the existing Rule to set WF

- Save the Request Type

- Create New Rule to Set WF at Creation again.

- Save the Request Type.

 

This could help if somehow your first Rule is not executing for some reason.

One Screenshot for Rule attached.

 

Good Luck !

-Raj

Jason Nichols K
Acclaimed Contributor.

Re: Workflow Isuue

I would recommend changing the Rule to use Advanced defaults instead of simple.  I'm sure you can find several instances of people on this forum seeing the same thing.  The workflow is not set when using the Simple Defaults.  You would then set the Logic to be SELECT workflow_id, workflow_name from KWFL_WORKFLOWS WHERE workflow_name = 'Defect Request Workflow'.

Jim Esler
Acclaimed Contributor.

Re: Workflow Isuue

What version of PPM are you running?  The simple rule for setting workflows on creation has problems at various release levels. We found that it was severely broken at 9.12. HP provided a hot fix to us at that level and it is resolved in 9.14. The problem appeared to be that the simple rule was using some hidden dependencies on other fields in the header for the trigger and some default values we set on those fields caused the rule to be bypassed.

Pachi
Super Contributor.

Re: Workflow Isuue

@JIM: the version we are in is

HP PPM (7.1.0 SP6)

 

@jason: the workflow ID i am getting after running the qury is 31642,

Regards,
Pachi
Jim Esler
Acclaimed Contributor.

Re: Workflow Isuue

We moved directly from 6.0 to 7.5 so I have no experience with 7.1. However, you can get some idea what the simple rule is doing by opening it, then changing the Rule Type from Simple to Advanced. This will show you some field name dependencies that it is using that could be affecting the execution of the rule. I do NOT recommend using the advanced rule that results from this action. You should Cancel this change as the resulting rule will not work properly if you migrate it to another PPM instance since it uses the workflow id, not the workflow name. Of course, it could be modified at this point to work properly.

Pachi
Super Contributor.

Re: Workflow Isuue

How do i do that?

 

How do i get the advance option? or were can i update the workflow ID directly?

Regards,
Pachi
Jim Esler
Acclaimed Contributor.

Re: Workflow Isuue

Open the request type in the Workbench. Click the Rules tab. Edit the rule that is setting the workflow name. Click the dropdown for Rule Type and select Advanced.