Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade failed from 8.0 to 9.10

Highlighted
WissenCarquest
Regular Collector

Upgrade failed from 8.0 to 9.10

Hello All,

 

We have started upgrade PPM application from 8.0 to 9.10. It was failed with below errors.

 

BUILD FAILED
/home/mitg/PPM_HOME/upgrade_910/xml/upgrade.xml:109: java.sql.SQLException: ORA-06510: PL/SQL: unhandled user-defined exception
ORA-06512: at line 84


Total time: 5 minutes 47 seconds
java.sql.SQLException: ORA-06510: PL/SQL: unhandled user-defined exception
ORA-06512: at line 84

 

Please find the attached logs.

 

Thanks,

Prasad a

8 REPLIES
Niraj Prabhu
Frequent Visitor

Re: Upgrade failed from 8.0 to 9.10

Prasad,

Looks like the TRIG_CREATE sql script is failing with error :"Trigger Upgrade Error. Error in Generating Triggers".

Can you check if the DB Schema user you are using for PPM, has enough access to create triggers in the database. Work with your DBA to resolve the access grant issue if any.
Niraj P.
WissenCarquest
Regular Collector

Re: Upgrade failed from 8.0 to 9.10

Hello Niraj,

 

We are able to create trigger.

 

Thanks,

Prasad A

WissenCarquest
Regular Collector

Re: Upgrade failed from 8.0 to 9.10

Hello Niraj,

 

While attached script run, The upgrade was failed.

 

Thanks,

Prasad A

Niraj Prabhu
Frequent Visitor

Re: Upgrade failed from 8.0 to 9.10

Prasad,

 

I would suggest to check the triggers at the DB level to make sure that those are created as expected. If you think they have been successfully created, then resume the upgrade. There is no harm in doing this as the upgrade should resume from the point where it last stopped. See if the error remains?

 

Niraj P.
WissenCarquest
Regular Collector

Re: Upgrade failed from 8.0 to 9.10

Hello Niraj,

 

While attached sql script run, We got below error message.

ORA-06510: PL/SQL: unhandled user-defined exception
ORA-06512: at line 84

Thanks,

Prasad A

Diego Aguila
Occasional Contributor

Re: Upgrade failed from 8.0 to 9.10

Hi, we have the same error in a upgrade from 8.0 to 9.10 ..

someone could resolve this error??

 

thanks in advance,

 

Diego.

Niraj Prabhu
Frequent Visitor

Re: Upgrade failed from 8.0 to 9.10

Prasad, Can you please share the resolution with Diego?

 

Diego, Please feel free to upload upgrade logs and screenshots to help us understand this issue.

 

Regards,

Niraj

Niraj P.
IBayraktar
Super Collector

Re: Upgrade failed from 8.0 to 9.10

Hi all, 

 

We have same error during upgrade from 8.04 -> 9.1

Can you share solution, please? 

 

Best regards,

I. Bayraktar

//Add this to "OnDomLoad" event