Project and Portfolio Management Practitioners Forum

Unable to stop server

Go to solution
Super Contributor.

Unable to stop server

Hi All,


After dev url is typed , page loads after 2mins, and then after giving credentials takes atleast 4 to 5 minutes to log in.

If clicked on search requests or any other operation in the front end takes minimum of 5 minutes pageloading .

So decided to stop the server and delete temp and work directories and rstart the server. 


I have tried to stop server using sh -name kintana -now -user admin

 then wheni check the status of command using below commnads i got the following message even after one hour.


Version of is DEV PPM 9.14


-bash-4.1$ sh -name kintana
JAVA_HOME = /opt/mitg/java/jdk1.6.0_38
java version "1.6.0_38"
Java(TM) SE Runtime Environment (build 1.6.0_38-b05)
Java HotSpot(TM) 64-Bit Server VM (build 20.13-b02, mixed mode)
Server Name provided kintana
Checking rmi://
--> running, but shutdown in progress (load: 0.0, mode: NORMAL)



When try to load the dev URL now it is showing in browser as 


HTTP Status 503 - This application is not currently available
type Status report
message This application is not currently available
description The requested service (This application is not currently available) is not currently available.
Apache Tomcat/5.5.31






Jim Esler
Acclaimed Contributor.

Re: Unable to stop server

When the service does not shut down on its own, it is necessary to kill it. On a Unix system, this is done with a kill -9 command.

Super Contributor.

Re: Unable to stop server

Thanks Jim for the reply.


When typed following command i got below one. which i need to kill? (Here admin user to which we will be connected using our user by sudo su - mitg.)




-bash-4.1$ ps -ef|grep mitg
mitg 1850 1 3 2013 ? 2-12:19:36 /opt/mitg/java/jdk1.6.0_38/bin
/java -server -server -DNAME=kintana -Djava.endorsed.dirs=/opt/mitg/PPM_HOME/lib
/endorsed -Djboss.home.dir=/opt/mitg/PPM_HOME -Djboss.lib.url=file:/opt/mitg/PPM
_HOME/lib/jboss/server -Dlog4j.configuratorClass=com.kintana.core.logging.LogCon
figurator -Dlog4j.configuration=logging.conf -Dlog4j.debug=false -Dcom.kintana.c
ore.server.SERVER_NAME=kintana -Dcom.kintana.core.logging.ENABLE_LOGGING_LOGS=fa
lse -Dcom.kintana.core.logging.APPLICATION_LOCATION=server -Dcom.kintana.core.lo
er/kintana/tmp -Djboss.platform.mbeanserver
rg.jboss.system.server.jmx.MBeanServerBuilderImpl -Dorg.owasp.esapi.resources=/o
pt/mitg/PPM_HOME/server/kintana/esapi-props/ -Dcom.kintana.core.server.KINTANA_S
ERVER_MODE=standalone -Dorg.apache.jasper.compiler.Parser.STRICT_QUOTE_ESCAPING=
false -Djgroups.marshalling.compatible=true -Dor
g.jgroups.conf.magicNumberFile=/opt/mitg/PPM_HOME/conf/jg-magic-map.xml -Xms1280
m -Xmx1280m -XX:+HeapDumpOnOutOfMemoryError -XX:MaxPermSize=256m -XX:+UseParalle
lGC -Djava.awt.headless=true org.jboss.Main -c kintana
mitg 4944 13552 0 2013 ? 00:00:00 /d01/app/oracle/product/11G/bin/
sqlplus @transfers/TMP_service_node_0/tmp_get_sqlplus_versi
mitg 13552 1 0 2013 ? 09:02:08 /opt/mitg/java/jdk1.6.0_38/bin/j
ava -server -server -DNAME=service_node -Djava.endorsed.dirs=/opt/mitg/ITGQAHOME
/lib/endorsed -Djboss.home.dir=/opt/mitg/ITGQAHOME -Djboss.lib.url=file:/opt/mit
g/ITGQAHOME/lib/jboss/server -Dlog4j.configuratorClass=com.kintana.core.logging.
LogConfigurator -Dlog4j.configuration=logging.conf -Dlog4j.debug=false -Dcom.kin
tana.core.server.SERVER_NAME=service_node -Dcom.kintana.core.logging.ENABLE_LOGG
ING_LOGS=false -Dcom.kintana.core.logging.APPLICATION_LOCATION=server -Dcom.kint
tg/ITGQAHOME/server/service_node/tmp -Djboss.platform.mbeanserver -Djavax.manage
ment.builder.initial=org.jboss.system.server.jmx.MBeanServerBuilderImpl -Dorg.ow
asp.esapi.resources=/opt/mitg/ITGQAHOME/server/service_node/esapi-props/ -Dcom.k
ter -Dorg.apache.jasper.compiler.Parser.STRICT_QUOTE_ESCAPING=false
referIPv4Stack=true -Djgroups.marshalling.compatible=true -Dorg.jgroups.conf.mag
icNumberFile=/opt/mitg/ITGQAHOME/conf/jg-magic-map.xml -Xms1280m -Xmx1280m -XX:+
HeapDumpOnOutOfMemoryError -XX:MaxPermSize=256m -XX:+UseParallelGC -Djava.awt.he
adless=true org.jboss.Main -c service_node
mitg 15669 1 0 2013 ? 02:00:40 /opt/mitg/java/jdk1.6.0_38/bin/j
ava -server -server -DNAME=kintana -Djava.endorsed.dirs=/opt/mitg/ITGQAHOME/lib/
endorsed -Djboss.home.dir=/opt/mitg/ITGQAHOME -Djboss.lib.url=file:/opt/mitg/ITG
QAHOME/lib/jboss/server -Dlog4j.configuratorClass=com.kintana.core.logging.LogCo
nfigurator -Dlog4j.configuration=logging.conf -Dlog4j.debug=false -Dcom.kintana.
core.server.SERVER_NAME=kintana -Dcom.kintana.core.logging.ENABLE_LOGGING_LOGS=f
alse -Dcom.kintana.core.logging.APPLICATION_LOCATION=server -Dcom.kintana.core.l
rver/kintana/tmp -Djboss.platform.mbeanserver
=org.jboss.system.server.jmx.MBeanServerBuilderImpl -Dorg.owasp.esapi.resources=
/opt/mitg/ITGQAHOME/server/kintana/esapi-props/ -Dcom.kintana.core.server.KINTAN
A_SERVER_MODE=clustered -Dorg.apache.jasper.c
ompiler.Parser.STRICT_QUOTE_ESCAPING=false -Djgr
oups.marshalling.compatible=true -Dorg.jgroups.conf.magicNumberFile=/opt/mitg/IT
GQAHOME/conf/jg-magic-map.xml -Xms1280m -Xmx1280m -XX:+HeapDumpOnOutOfMemoryErro
r -XX:MaxPermSize=256m -XX:+UseParallelGC -Djava.awt.headless=true org.jboss.Mai
n -c kintana
mitg 18534 30481 0 11:28 pts/3 00:00:00 ps -ef
mitg 18536 30481 0 11:28 pts/3 00:00:00 grep mitg
root 30479 30396 0 09:23 pts/3 00:00:00 sudo su - mitg
root 30480 30479 0 09:23 pts/3 00:00:00 su - mitg
mitg 30481 30480 0 09:23 pts/3 00:00:00 -bash


Please help me on this.




Jim Esler
Acclaimed Contributor.

Re: Unable to stop server

It looks like you are running two nodes on this server and are trying to kill the one named kintana. There appear to be two processes running with that name and that may be related to the reason it is hung up and won't stop. Kill those two processes, then restart that node.

Super Contributor.

Re: Unable to stop server

Thanks Jim. It worked.