The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to open workbench on desktop

SOLVED
Go to solution
Highlighted
riznad
Regular Collector

Unable to open workbench on desktop

Hi;
I login to the ppm system as admin user.
I opened Open > Administration > Open workbench on desktop
Tehn an error message is shown on java.
Ubable to lunch application
LOUNCH FILE TAB:

<?xml version="1.0" encoding="UTF-8"?>
<jnlp href="html/workbench.jnlp" codebase="http://SP-PPMAPP01:8080/itg/">
<!-- DO NOT EDIT THIS FILE - IT IS BEING PARSED BY THE ITG SERVER -->

<information>
<title>HP Project and Portfolio Management Workbench</title>
<vendor>HP</vendor>
<homepage href="http://www.mercury.com"/>
<description>Enables to start PPM Workbench as a Desktop Application using Java Web Start</description>
<icon href="html/Mercury-icon-big.gif" width="64" kind="default"/>
<icon href="html/Mercury-icon-small.gif" width="32" kind="default"/>
<icon href="html/MercurySplash-70.gif" kind="splash"/>
<shortcut online="true">
<desktop/>
<menu submenu="HP"/>
</shortcut>

</information>

<security>
<all-permissions/>
</security>

<resources>
<j2se version="1.4+ 1.5+"/>
<jar href="html/client/knta_client.jar"/>
<jar href="html/client/acme.jar" download="lazy"/>
<jar href="html/client/crypto.jar" download="lazy"/>
<jar href="html/client/jacob.jar" download="lazy"/>
<jar href="html/client/jacob_dll.jar" download="lazy"/>
<jar href="html/client/jakarta_regexp_1_3.jar" download="lazy"/>
<jar href="html/client/knta_jimi.jar" download="lazy"/>
<jar href="html/client/knta_log4j.jar" download="lazy"/>
<jar href="html/client/krmi.jar" download="lazy"/>
<jar href="html/client/looks-2.0.4.jar" download="lazy"/>

<extension name="Unsigned Jars" href="html/unsignedJars.jnlp"/>
</resources>

<application-desc main-class="com.kintana.core.gui.LogonApplet">
<argument>rmi://SP-PPMAPP01:1099/KintanaServer</argument>
<argument>-locale</argument>
<argument>en</argument>
<argument>-country</argument>
<argument>US</argument>
<argument>-baseURL</argument>
<argument>http://SP-PPMAPP01:8080/itg/</argument>
</application-desc>

</jnlp>

exception:

java.lang.NullPointerException
at com.kintana.core.gui.LogonApplet.loadInstalledLanguages(LogonApplet.java:229)
at com.kintana.core.gui.LogonApplet.init(LogonApplet.java:289)
at com.kintana.core.gui.LogonApplet.main(LogonApplet.java:1066)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.sun.javaws.Launcher.executeApplication(Unknown Source)
at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
at com.sun.javaws.Launcher.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Could you help me please?

5 REPLIES
Kerim KILIC
Frequent Visitor

Re: Unable to open workbench on desktop

can you put SP-PPMAPP01 ip address to host file?
riznad
Regular Collector

Re: Unable to open workbench on desktop

where is the location of the host file?

Celil
Esteemed Contributor

Re: Unable to open workbench on desktop

Hi,

 

Genrally this error can get when your host name doesn't match with an IP. You can do this in "hosts" file in C:\Windows\System32\drivers\etc folder in windows systems. You can enter a line like this:

SP-PPMAPP01 195.32.211.132

 

 

PS: If the post resolves your issue, please KUDOS the professionals and mark it as Accepted Solution.

Celil

IT Governance Professional
& PPM Solution Architect
riznad
Regular Collector
Solution

Re: Unable to open workbench on desktop

Hi;

problem is solved.

The problem occured because administrator group changed firewall settings.

They rollbacked.

Problem is solved.

Thansk for your interest.

SowmyaDivi
Acclaimed Contributor

Re: Unable to open workbench on desktop

I copied <hostname> <ipaddress> of my machine in hosts fine but still no luck :(

Pls help me out in resolving this.

//Add this to "OnDomLoad" event