Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to open browser from Workbench

SOLVED
Go to solution
Highlighted
Derek Giedd
Frequent Visitor

Unable to open browser from Workbench

In workbench I have set my default browser as IE.  When in Deployment Mgmt and attempting to view the exection log or editing a request type layout and attempting to preview the layout I get the following message.

 

The default browser you entered (C:\Program Files (x86)\Internet Explorer\iexplore.exe) is not valid or will not run. Please open the User Profiles dialog and select a new Default Browser from the General tab.

 

We have 2 instances of PPM (V8 & V9.21).  This occurs in both.  Other users do not have this problem so it is definitely a problem with my PC.  I have IE8 installed.  I have both JRE 1.7.45 and 1.7.25 installed.  I have enabled each individually with no change.

-- Remember to give Kudos to answers! (click the KUDOS star)
8 REPLIES
Utkarsh_Mishra
Honored Contributor

Re: Unable to open browser from Workbench

Simple open the Workbench->Edit (Menu) -> User Profile -> and select the Internet Explore.exe file path in the Deafult Browser field. (you put any other browser path as well).

 

Below is the snippet.

 

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
Derek Giedd
Frequent Visitor

Re: Unable to open browser from Workbench

That was already done.  In fact I have tried both IE and Chrome.

-- Remember to give Kudos to answers! (click the KUDOS star)
Linda Gregory
Super Collector

Re: Unable to open browser from Workbench

I am having this same issue. My default browser id defined as well.  Can you remember what you were able to do to fix this?

 

Thanks

Linda Gregory
Super Collector

Re: Unable to open browser from Workbench

Found resolution somewhere else,  Do not use option open workbench on desktop, use regular open workbench

Utkarsh_Mishra
Honored Contributor

Re: Unable to open browser from Workbench

I found this in HP portal, hope it helps to resolve the issue

 

Customer symptom

PPM Workbench (v8.01 w/ JRE 1.7.0_21) failed to open a package execution log: 

"The default browser you entered (C:\Program Files (x86)\Internet Explorer\iexplore.exe) is not valid or will not run. Please open the User Profiles dialog and select a new Default Browser."

Workaround

use JRE 1.7.0 Update 17 for WB opening.
Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
Derek Giedd
Frequent Visitor
Solution

Re: Unable to open browser from Workbench

It turns out that the solution was not the Java version, but I had to re-create my Windows user profile.  I could log in to a different PC and this function worked fine.  We finally renamed my user folder and I logged back in, recreating the profile.  Now I just have to get everything set back up.

-- Remember to give Kudos to answers! (click the KUDOS star)
Scorpex
Member

Re: Unable to open browser from Workbench

This might be a bit old but I had the same issue today and noticed that if you use the little page icon to browse for the default browser, PPM puts it without quotes and thus generates the error (this is what happened in my case)

 

 

I added the quotes to "C:\Program Files\Internet Explorer\iexplore.exe" and it worked fine.

 

Hope this helps!

Mig

karthikc
Acclaimed Contributor

Re: Unable to open browser from Workbench

Brilliant!!! This simple solution resolved the issue for me. Many thanks!!
//Add this to "OnDomLoad" event