Project and Portfolio Management Practitioners Forum
cancel

Unable to create new validation on workbench

SOLVED
Go to solution
Highlighted
Christoph Pflau
Contributor.

Unable to create new validation on workbench

It is no longer possible to create new validations on the workbench. After opening the form for new validations, no entries can be made. Even selecting items in a drop down list is impossible. However existing validations or other objects can be changed without problems. Any suggestion for this strange behavior?

We are using PPM-Center Version 8.00.
6 REPLIES
Sascha Mohr_1
Outstanding Contributor.

Re: Unable to create new validation on workbench

We're running 8.0.1 and I have not seen this yet. Did you check that your user has all three config access grants related to validations? I think, would you described would be the case if you just had the grant "Konfig. Validierungswerte bearbeiten"
Christoph Pflau
Contributor.

Re: Unable to create new validation on workbench

The user has all rights you can grant in PPM-Center. So there must be another reason. I suppose an error in the PL/SQL-Package for the creation of new validations.
Sascha Mohr_1
Outstanding Contributor.

Re: Unable to create new validation on workbench

I had a look at the release notes of SP1, but the issue is not mentioned there. You should probably open a case with HP support. If you can identify the pl/sql package I can upload it from one of my instances of course.
Raj Ghimire
Outstanding Contributor.
Solution

Re: Unable to create new validation on workbench

Are these Drop down field validations ?
Have you checked the "USER_MAINTAINABLE_FLAG" in KNTA_LOOKUPS table. Is it "Y" ?
I wonder if that has something to do ?

-Raj
Christoph Pflau
Contributor.

Re: Unable to create new validation on workbench

It was in fact an error in the table KNTA_Lookups. After running an update script everything worked normal again. Here are the details:

There are some validations that are used to define text fields. You can see these with the following SQL statement;

SELECT lookup_code, meaning, default_flag
FROM knta_lookups
WHERE lookup_type = 'DATA_MASK'
AND enabled_flag = 'Y'
AND user_data1 = 'Y'
ORDER BY seq

user_data1 and visible_user_data1 are intended to be 'Y' for this lookup. If you compare to a working instance, then you will see 3 lookup_codes with a 'Y' value. These lookup_codes are 'ALPHA', 'ALPHA_UPPER',
'NUMERIC'.

The following SQL was used to update the scema with the correct values.

UPDATE knta_lookups
SET user_data1 = 'Y', visible_user_data1='Y'
WHERE lookup_type = 'DATA_MASK'
and lookup_code in ('ALPHA','ALPHA_UPPER', 'NUMERIC')

After this update was committed we were able again to create new validations.
Christoph Pflau
Contributor.

Re: Unable to create new validation on workbench

See my comments above.