Project and Portfolio Management Practitioners Forum

Unable to Launch Workbench


Unable to Launch Workbench

On PPM 9.20 I get an error when I try to launch the desktop workbench. I used to be able to launch it a couple weeks ago and to my knowledge nothing was changed on the server where PPM runs. Every other person is able to launch it in their computers. I even tried accesing it through an Admin account in my computer and it launched without any problems. The issue only happens on my end. I've tried clearing the java cache and files (applets, etc), clearing the internet explorer files and reinstalling java. Right now I have java 7 11 which is the one I have always used when I used to be able to access the workbench. 


I also cannot access it through the web but this has always been a problem, I'm more interested in solving the problem with the desktop workbench.


Here is the 'exception' log I get:




Error: javax.servlet.http.Http.ServletRequest


java.lang.ClassNotFoundException: javax.servlet.http.HttpServletRequest
at$ Source)
at$ Source)
at Method)
at Source)
at com.sun.jnlp.JNLPClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
at java.lang.Class.getMethod0(Unknown Source)
at java.lang.Class.getMethod(Unknown Source)
at com.kintana.core.logging.Logger.getMethods(
at com.kintana.core.logging.Logger.logExM(
at com.kintana.core.logging.Logger.error(
at com.kintana.core.gui.CLApplet.saveLookAndFeel(
at com.kintana.core.gui.CLApplet.getLookAndFeel(
at com.kintana.core.gui.LogonApplet.init(
at com.kintana.core.gui.LogonApplet.main(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.sun.javaws.Launcher.executeApplication(Unknown Source)
at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
at Source)
at Source)




Any help is appreciated!

Super Contributor.

Re: Unable to Launch Workbench

What version of Java do you have on your desktop?

We have experienced numerous issues with the workbench based upon the version of Java installed on the user's machine.

One of the most straightforward solutions was to simply uninstall all versions of java via the Control Panel, and then allow PPM to install its version when you attempt to fire up the workbench.

If you need particular version(s) of java for other applications you run, then that is where the real fun begins...


Re: Unable to Launch Workbench

Thank you very much for your reply. I was using version 7_11 of java when the issue started ocurring. I uninstalled and installed every possible version of java that I could get my hands on and the issue persisted. I checked every possible java/web browser/system setting I could think of against one of my coworker's settings and nothing worked. I was only left with the option of formatting my computer yesterday.


This fixed the issue. I installed version 7_65 which my coworker uses and it worked with no problems.


But today I came across the exact same issue. I am getting again the same error and I'm again unable to open the workbench. Nothing was changed or done to my computer, java wasn't updated either. My computer was simply turned off yesterday and turned on again today. When I try to open the workbench I am getting the same error.


What could possibly be happening?!