Project and Portfolio Management Practitioners Forum
cancel

The LDAP Server could not be reached

Highlighted
Prabha N
Trusted Contributor.

The LDAP Server could not be reached

Hi all,

We are using HPPPM 8 and windows server 2008 R2 AD server(upgraded recently) as your ldap target server

When we try logging in it shows,
"The LDAP Server could not be reached.Please validate the LDAP_URL parameter in the server.conf. (KNTA-10843)"

And the server log is given below:
------------------------------------------------at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:748)
at java.lang.Thread.run(Thread.java:619)
JSESSIONID=A3818D218F6E5F9E2147782EAD5AA374.PPM_PROD01_N1,USERNAME= server:http-0.0.0.0-8089-Processor22:com.kintana.sc.authentication:2010/11/03-10:52:41.132 CET: Der LDAP-Server konnte nicht erreicht werden. Validieren Sie den Parameter LDAP_URL in der server.conf. (KNTA-10843)
nested detail:simple bind failed: SERVERNAME:3269
------------------------------------------------

Please let us know if any problem with PPM conenctivity?
5 REPLIES
Mahen M
Acclaimed Contributor.

Re: The LDAP Server could not be reached

Though not an expert in this, I think you are trying to use Java Naming Directory Interface (JNDI, where it will register Server details with a alias name) and in that it failed to add the servername 3269 (could be due to port/ name available already)

Hope you are using single LDAP URL in server.conf, If you are using more than one URL hope it is seperated by comma.

Have you specified PPM Credentials in LDAP Server?

Some links:
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1302375

http://social.technet.microsoft.com/Forums/en-US/winserverDS/thread/183a8f2c-0cf7-4081-9110-4cf41b91dcbf/#5bd78fa4-afcf-4755-9d0b-a8b38cb18347

Regards,
Mahendran M
Prabha N
Trusted Contributor.

Re: The LDAP Server could not be reached

Thanks Mahen!

We tried it. But still we face the same issue.Also we tried importing the latest CA certificates.When we tried pinging from LDAP browser, it worked very much fine.

LDAP was working fine until last week.


Regards,
Prabha
Jim Esler
Acclaimed Contributor.

Re: The LDAP Server could not be reached

Have you tried stopping and restarting PPM? By default, PPM caches the DNS information for the LDAP server forever. If AD is no longer running on that server, you would get this error until PPM's DNS cached value is purged.
Daniel Galvez
Super Contributor.

Re: The LDAP Server could not be reached

Hi Prabha,

It seems that that PPM could not authenticate to the LDAP server, you have to verify the following steps:

1.- In cmd window telnet IP_LDAP LDAP PORT, if it does not work it seems that you have an issue with the ports
2.- Are you using LDAPS? If yes verify the server certificate.
3.- Try to connect to the ldap server with an LDAP client from the PPM server, if it works delete all the cache information from PPM server and restart the service.

I think that tour problem is in the authentication and it could be the certificate or maybe a wrong password.

Kind regards,
Daniel
Catherine Curti
Respected Contributor.

Re: The LDAP Server could not be reached

Are you authenticating against multiple domains? Could be some settings changed on the LDAP side that broke the connection. I second downloading a LDAP tool to verify the connection.