Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Table component columns' tokens seems like plain text

Highlighted
BerkMorkoc
Occasional Contributor

Table component columns' tokens seems like plain text

Hi,

 

I'm trying to add some table component columns to notification template.

But whatever I tried, system send HTML notification as a plain text. (Notification Template is in HTML format)

 

I've a format like [REQD.T.table.TC.P.column_name], and I also tried these combinations;

[REQD.T.table.TC.VP.column_name],

[REQD.T.table.column_name] etc. 

 

Thanks for all answers.

 

Berk

9 REPLIES
Loc_Nguyen_PPM
Occasional Visitor

Re: Table component columns' tokens seems like plain text

Hi Berk,

 

PPM is ommitting the "." in front of the style sheets in HTML code before sending the notifications. As a result, notification appears as plain text Check for the server.conf parameters SMTP_RFC_COMPLIANCE and SMTP_ADD_PERIOD parameters should be set to true:

 

com.kintana.core.server.SMTP_RFC_COMPLIANCE=true

com.kintana.core.server.SMTP_ADD_PERIOD=true

 

run kUpdateHtml.sh and restart PPM servers

 

Hope this help.

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
BerkMorkoc
Occasional Contributor

Re: Table component columns' tokens seems like plain text

Hi vinhloc81,

 

I changed the parameters but it's not solved my problem.

 

I also changed Notification Template plain to HTML or HTML to plain.

When system send notificiation mails, tokens still visible as [REQD.T...]

 

Thanks for answers.

 

pepdwill
Senior Member

Re: Table component columns' tokens seems like plain text

I would strongly advise using the "token builder" to ensure you are using the correct syntax for the token.

Loc_Nguyen_PPM
Occasional Visitor

Re: Table component columns' tokens seems like plain text

Hi,

 

After changed the server.conf parameters. Did you run kUpdateHtml.sh ? It is  very important for applied the change in server.conf.

This is  exactly the things  you need to do:


1) Open the server.conf file under PPM_HOME directory
2) Stop the PPM server
3) Set the following parameters:
com.kintana.core.server.SMTP_RFC_COMPLIANCE=true
com.kintana.core.server.SMTP_ADD_PERIOD=true
4) Run the kUpdateHtml.sh file from a command line from PPM_HOME/bin directory
5) Restart the PPM server

Is your SMTP server running on a Linux machine or Window machine ?

 

Thanks.

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
BerkMorkoc
Occasional Contributor

Re: Table component columns' tokens seems like plain text

Hi,

 

vinhloc81I followed your instruction but situation did not change.

Our SMTP server running on Windows.

 

pepdwill, as you said, I collect tokens from Token Builder.

 

Is there any idea? Thanks for all...

Loc_Nguyen_PPM
Occasional Visitor

Re: Table component columns' tokens seems like plain text

Hi,

 

I found the document about  table component tokens. Please take a look.

 

http://support.openview.hp.com/selfsolve/document/KM186332

 

I saw in this document all names in the token needs to be with capital letters.

So.

[REQD.T.table.TC.P.column_name] 

it has to be [REQD.T.TABLE.TC.P.COLUMN_NAME]

 

One thing. Can you provide for me the serverLog.txt file for troubleshooting.

 

Thanks.

 

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
BerkMorkoc
Occasional Contributor

Re: Table component columns' tokens seems like plain text

Hi,

 

I have already tried these but problem still happening.

 

Thanks for your help.

 

 

pepdwill
Senior Member

Re: Table component columns' tokens seems like plain text

Berk - did you ever figure this out?

BerkMorkoc
Occasional Contributor

Re: Table component columns' tokens seems like plain text

I've added new notification template and coded new HTML into it. This resolved table component fields but we have still problem with user defined tokens.

We are getting support from HP about this issue.

//Add this to "OnDomLoad" event