Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Single Sign-on question

Highlighted
TurboMan
Member

Single Sign-on question

Hi,

 

I've upgraded from 7.5 SP7 to 8.04 with single sing-on working on 7.5.
After upgrade single sign-on didn't work.
Then I tried to make the TEST mork with the single sing-on.
I followed the instructions on how to implement the single sing-on in the PPM 8.00Installation Manuel.
But it didn't help I keep getting the following error.
DEBUG JSESSIONID=BD2A6867DA907B61031A026D088CA7C7.TEST,USERNAME= server:http-0.0.0.0-8080-Processor25:com.kintana.sc.authentication:2011/10/14-22:32:44.038 EEST: checkLogonRequired: true

I use Windows Server 2003 and IIS6.

 

Any help is appreciated.

Regards
TM

4 REPLIES
dirkf
Honored Contributor

Re: Single Sign-on question

Hi TM,

 

I'm missing two pieces of information.

1) Which SSO-solution are you trying to implement with PPM and IIS - Siteminder?

2) I believe the stack trace that you published could be incomplete. I'd be expecting more to come... something like:

 

(I've tweaked off the usual PPMlog-preliminaries, only want to show the interesting stuff)

 

JSESSIONID blablablabla :

checkLogonRequired: true
logon: is report submission = false
logon: checking old session user = null
SiteMinder: SM_USER = null
SiteMinder: SM_USER = null

Best regards,

Dirk

TurboMan
Member

Re: Single Sign-on question

Thanks Dirk,

 

I am trying to implement IIS solution.

I've attached the trace file.

Thanks

Regards

dirkf
Honored Contributor

Re: Single Sign-on question

Hi TM,

 

the errors shown in the stack are pointing to the SSO username:

Check the sso-configuration to make sure that not only the header is set but also the name.

 

Refer to sys. adm guide (Troubleshooting Single Sign-On section) to see how to configure and troubleshoot this issue.

You can also use Fiddler to see what IIS is sending to PPM.

 

Best regards,

Dirk

SSO USER HEADER : IV_USER
DEBUG JSESSIONID=796979015C658ABDF18FD241C741C254.TEST,USERNAME= server:http-0.0.0.0-8080-Processor25:com.kintana.sc.authentication:2011/10/15-15:50:47.071 EEST: SSO USER NAME : null
Kerim KILIC
Frequent Visitor

Re: Single Sign-on question

hi,

are you able to login application via ldap authentication? if you are not, you need to replace ldap_attributes conf file after upgrade; check ldap configuration in guiedes.

regards
//Add this to "OnDomLoad" event