Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Setting up the WB as a Stand-Alone Application

Highlighted
Surendra Poosar
Frequent Visitor

Setting up the WB as a Stand-Alone Application

Hi,

I am facing a problem while setting up the Workbench as a Standalone application.
As per the SysAdmin UG we need to copy the following jar files
from the ITG_Home/html/client and ITG_Home/classes directories into a
single directory accessible by the client machine:

􀀀 ITG_Home/server/kintana/deploy/itg.war/
WEB-INF/lib/knta_classes.jar
􀀀 ITG_Home/server/kintana/deploy/itg.war/
WEB-INF/lib/libraries.jar
􀀀 ITG_Home/server/kintana/deploy/itg.war/
WEB-INF/lib/oracle-jdbc.jar

I am able to find the knta_classes.jar and the libraries.jar in the
...\deploy\itg.war\WEB-INF\lib
but the oracle_jdbc.jar exists in the
...\lib folder.

So when I try to create a kintana.bat windows as per the following file :

@ECHO OFF
REM
REM Change to your client install directory.
REM
cd /D e:\Programs\Kintana
set classpath=.
set classpath=%classpath%;.\knta_classes.jar
set classpath=%classpath%;.\libraries.jar
set classpath=%classpath%;.\oracle-jdbc.jar
REM
REM Change to the host and RMI port of your primary Mercury
ITG Server.
REM
jview /p /cp %CLASSPATH% com.kintana.core.gui.LogonApplet
your_company.domain.com:1200

it is throwing an error as follows

** Your URL: rmi://GCMS.global.bcecorp.net:1099/KintanaServer/KintanaServer
Exception in thread "main" java.lang.NoClassDefFoundError: java/awt/HeadlessExce
ption
at com.kintana.core.gui.beans.CLTextField.clInit(CLTextField.java:433)
at com.kintana.core.gui.beans.CLTextField.(CLTextField.java:464)
at com.kintana.core.gui.LogonApplet.init(LogonApplet.java:215)
at com.kintana.core.gui.LogonApplet.main(LogonApplet.java:894)

Is there a solution to open the WB as a client?
5 REPLIES
Darshan Bavisi
Occasional Visitor

Re: Setting up the WB as a Stand-Alone Application

Hi Surendra,

The jar file paths in the sys admin guide is incorrect. HP Support earlier (when Mercury) had agreed and put an enhancement request for updating/correcting their documentation.

The files you got from lib, etc. folders are correct.

In the bat file, make the following changes,

1. Modify the cd /D e:\Programs\Kintana to the path where you have stored these jar files. If you hae stored in e:\Programs\Kintana itself then modify the line as below,

e:
cd programs\kintana

Otherwise the best way is to keep the .bat file in the same folder where you have kept the jar files on your local machine. That way you won't have to add the above line at all. Then create a shortcut of the .bat file on your desktop, so its easily accessible.

Also, try not using the jview, instead use,

java com.kintana.core.gui.LogonApplet... etc. that line.

You may have to install JDK for that on your machine.

Let me know if this does not work, then we will go into more step-by-step details. I have done this setup on my machine many times.
Surendra Poosar
Frequent Visitor

Re: Setting up the WB as a Stand-Alone Application

Thanks Darshan.

I have copied the knta_classes.jar, libraries.jar, oracle_jdbc.jar, oracleapps.jar into a folder called KNTA_WB under C:.

I have changed the script as follows

@ECHO OFF

c:
cd KNTA_WB
set classpath=.
set classpath=%classpath%;.\knta_classes.jar
set classpath=%classpath%;.\libraries.jar
set classpath=%classpath%;.\oracle-jdbc.jar
set classpath=%classpath%;.\oracleapps.jar

java com.kintana.core.gui.LogonApplet GCMS.global.bcecorp.net:1099

but I am still getting the follwoing error:

The system cannot find the path specified.
** Your URL: rmi://GCMS.global.bcecorp.net:1099/KintanaServer
Exception in thread "main" java.lang.NoClassDefFoundError: java/awt/HeadlessExce
ption
at com.kintana.core.gui.beans.CLTextField.clInit(CLTextField.java:433)
at com.kintana.core.gui.beans.CLTextField.(CLTextField.java:464)
at com.kintana.core.gui.LogonApplet.init(LogonApplet.java:215)
at com.kintana.core.gui.LogonApplet.main(LogonApplet.java:894)


Darshan Bavisi
Occasional Visitor

Re: Setting up the WB as a Stand-Alone Application

Hi Surendra,

Try entering this on the command prompt:

echo %JAVA_HOME%

if it returns you the path of the java home then it is set.

Also, try removing the 'c:' from your bat file, if you are already on the c drive.

Also, try the IP address instead of the fully qualified DNS name.

If still doesn't work then let me know.
Surendra Poosar
Frequent Visitor

Re: Setting up the WB as a Stand-Alone Application

Darshan,

when I type echo %JAVA_HOME% I justget the following

C:\>echo %JAVA_HOME%
%JAVA_HOME%
Darshan Bavisi
Occasional Visitor

Re: Setting up the WB as a Stand-Alone Application

Hi Surendra,

Perfect, so that's all we need to know. This means that the Java Home is not set on your machine. Also, make sure you have JDK or JRE (check the compatibility matrix doc for your ITG/PPM version, which JDK version you will need) installed on your machine. To setup the JAVA_HOME environment variable you can do this,

On the desktop right click on the 'My Computer' icon > then select 'Properties' > then select 'Advanced' tab > then click on the 'Environment Variables' button,

then either in the User variables section or System variables section, click New then in 'Variable Name' field enter JAVA_HOME and in the 'Variable value:' field enter the path of the JDK or JRE something like 'C:\Progra~1\Java\jre1.5.0_06' (do not include blank space in the path). You won't need to enter the path upto the \bin folder of JDK/JRE but only upto the main JDK/JRE folder as in the above example.

Once that is done then you are all set and the Workbench should open from your machine as a standalone application.
//Add this to "OnDomLoad" event