Project and Portfolio Management Practitioners Forum
cancel

Server Start Error after PPM 7.5 SP7 Upgrade

SOLVED
Go to solution
Highlighted
aobisi
Contributor.

Server Start Error after PPM 7.5 SP7 Upgrade

Hi Experts,

 

I have successfully applied the SP7 patch with JAVA_HOME set to 'D:\Java\jdk1.6.0_29'

 

I used command line to start the server and I get the following error. I am running on Win 2003 SP2 machine and cgywin.

 

----------------------------------------

$ sh ./kStart.sh
JAVA_HOME = D:/Java/jdk1.6.0_29
java version "1.6.0_29"
Java(TM) SE Runtime Environment (build 1.6.0_29-b11)
Java HotSpot(TM) Client VM (build 20.4-b02, mixed mode, sharing)
Error: no `server' JVM at `D:\Java\jdk1.6.0_29\bin\server\jvm.dll'.

----------------------------------------

 

Any expert can shed some light?

 

Regards,

Alvis

7 REPLIES
Utkarsh_Mishra
Acclaimed Contributor.
Solution

Re: Server Start Error after PPM 7.5 SP7 Upgrade

Hi,

 

This issue is with JDK 1.6.0_29 64 bit verison.

 

As a resoultion try to upgrade the JDK to version JDK 1.6.0_30. For more details of the bug kindly refer to below links.

 

http://comments.gmane.org/gmane.comp.jakarta.commons.issues/16932

 

Or you can also try to follow steps given in the below link.

 

http://stackoverflow.com/questions/5941796/no-server-jvm-at

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
AlexSavencu
Acclaimed Contributor.

Re: Server Start Error after PPM 7.5 SP7 Upgrade

Hi,

My guess is that the jdk is not properly installed.

Cheers
Alex

--remember to kudos people who helped solve your problem
aobisi
Contributor.

Re: Server Start Error after PPM 7.5 SP7 Upgrade

Hi Utkarsh,

 

Thanks. Will get my guys to install 1.6.0_30 instead and see if the server jvm issue still occurs. I do not remember there is such issue before.

 

Regards,

Alvis

aobisi
Contributor.

Re: Server Start Error after PPM 7.5 SP7 Upgrade

Hi Alex,

Thanks for your reply. JDK is properly installed. And the JAVA_HOME and version can justify.

Regards,
Alvis
aobisi
Contributor.

Re: Server Start Error after PPM 7.5 SP7 Upgrade

Hi all,

 

Thank you guys for your inputs. I reinstalled JDK with JDK1.6.0_30 and server is running now.

 

And I think there is a need to perform a "ksvc sync" to refresh the parameters for PPM window service else the window service for PPM will not work.

 

 

Regards,

Alvis

 

AlexSavencu
Acclaimed Contributor.

Re: Server Start Error after PPM 7.5 SP7 Upgrade

Hi,

The best is to do ksvc remove and then ksvc install.

Cheers
Alex

--remember to kudos people who helped solve your problem
AlexSavencu
Acclaimed Contributor.

Re: Server Start Error after PPM 7.5 SP7 Upgrade

Hi,

 

I am not sure which is the solution - Utkarsh's or mine?

 

You did not provide kudos anyways :)

 

cheers

alex


--remember to kudos people who helped solve your problem