The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

SSL Configuration

SOLVED
Go to solution
Highlighted
Nilay___
Regular Collector

SSL Configuration

hi,

i defined following parameters and their information in server.conf file to configure SSL. Then i run sh kUpdateHtml and start ppm server. After SSL configuration i can open ppm page like https://name.com.tr  but can not pass the logün page. I log admin username and password but login page can't direct me to main ppm page.

Is there any extra parameters i need to define, or give any access or privileges for server ip.

 

 

com.kintana.core.server.ENABLE_SSL_LOGIN

com.kintana.core.server.HTTPS_PORT

com.kintana.core.server.HTTPS_WEB_THREAD_MIN

com.kintana.core.server.HTTPS_WEB_THREAD_MAX

com.kintana.core.server.HTTPS_KEYSTORE_LOCATION

com.kintana.core.server.HTTPS_KEYPASSWORD

com.kintana.core.server.BASE_URL

 

thanks.

4 REPLIES
Celil
Esteemed Contributor

Re: SSL Configuration

Hi Nilay,

book PPM9.10_InstallationAdmin page 109. Did you follow the this checklist?
Celil

IT Governance Professional
& PPM Solution Architect
Nilay___
Regular Collector

Re: SSL Configuration

hi Celil:)

 

i checked all parameter one by one from installation admin guide,

to make my mind clear there was one more parameter HTTPS_PROTOCOL (default value =TLS), and changed it from default value TLS to SSL.But it makes no changes to result. Still i can open ppm login page but when i enter user name and password and submit, a blank page opens and directs to itself continuously, like some kind of loop.

 

Nilay___
Regular Collector
Solution

Re: SSL Configuration

hi,

 

i found the reason why this problem occurs. Server.conf BASE_URL parameter needs to be defined without any port number just like http://xxx.aaa.com.tr   (wrong definiton was following--> http://xxx.aaa.com.tr:8080)

 

After i changed base url definiton problem fixed, but another problem occured unfortunately. In login page i log ppm username and password than submit but it takes over 1 or 1.5 minutes to direct ppm frontpage, but system returns its normal behaviour after i direct front page all dashboard modules runs quickly. Why could be the reason of slow login? Could it caused by SSL port 443?

Nilay___
Regular Collector

Re: SSL Configuration

hi all,
we fixed slowness problem either. Standart PPM dashboard's request list portlet's causes slow login.
To create a blank dashboard page and setting it as default page after login accelerates system login.
//Add this to "OnDomLoad" event