The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 10:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 10:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Running Report from workflow step

Highlighted
Tpower88
Occasional Advisor

Running Report from workflow step

I am trying to run a jsp report from a workflow step, I get the following error.  Anyone ever do this?  Any documentation on this out there anywhere?

 

I have tried everything, here is my code

 

ksc_run_jsp_report /web/knta/dsh/rpt/PortletDefReport.jsp
REPORT_ID=41795
USER_ID=102588
OUT_BASEFILE=rep_41795
ksc_end_report_parameters

 

Running report/web/knta/dsh/rpt/PortletDefReport.jsp
Posting report request tohttp://10.184.145.28:8080/itg/servlet/RunJspReport
Error running report.
Exhausted Resultset

java.sql.SQLException: Exhausted Resultset
at com.kintana.rpt.server.KSCRunJspReportCommand.logError(KSCRunJspReportCommand.java:310)
at com.kintana.rpt.server.KSCRunJspReportCommand.execute(KSCRunJspReportCommand.java:254)
at com.kintana.core.server.execution.CommandRunner.run(CommandRunner.java:118)
at java.lang.Thread.run(Thread.java:662)
1 REPLY
AbdulRafay
Super Collector

Re: Running Report from workflow step

I have not done that, but I am thinking along the same lines for one of the requirements that we have. What I could understand and gather the idea around goes like this:

 

1. In the request, before going on to the command execution step to run the report, query the knta_report_submissions_s sequence for the next available report id (store it in request token, REPORT_ID

2. In the command do something like:

 

ksc_run_jsp_report /web/knta/drv/rpt/myReport.jsp

 

REPORT_ID=[REQD.P.REPORT_ID]
USER_ID=[SYS.USER_ID]
OUT_BASEFILE=rep_[REQD.P.REPORT_ID].html
...


ksc_end_report_parameters

This is similar to what you are doing (assuming you are not using hard coded report_id value). The only difference I could see is that you do not have ".html" at the end of OUT_BASEFILE token. Maybe that would make the difference

 

As I said, I have not tried this concept as yet - but pretty soon will have to give it a go. Please keep us posted how does it go with you...

 

/Rafay

//Add this to "OnDomLoad" event