Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Request with strange status behavior

Highlighted
J. Yebusibí Lee
Occasional Contributor

Request with strange status behavior

1)The request was a step with the status of 'Waiting'.
2)The user click a button for advancing the workflow to another step with the status of 'Updating'.
3)Upon returning from the Updating step to the Waiting step the request did not change its status back to waiting but remained at 'Updating':
a)The question is how did this happen?
b)The workflow has the waiting status assigned to the step.
c)It does not happen to all requests
d)I clicked on the button again and this time, on the return it went back to waiting. (Strange I Know)
e)I may not find an answer with my current version 5.5.

Does anyone have any idea on this?
Thanks Lee.
6 REPLIES
B Swanson
Regular Collector

Re: Request with strange status behavior

We ran into something similar to this about a year or so ago in version 6.0. I believe it was a bug that was fixed in a later service pack. I am not sure about version 5.5.
J. Yebusibí Lee
Occasional Contributor

Re: Request with strange status behavior

Hi Swanson,

Really?, if you don't mind and if is possible I like to know what happend that time with your version 6.0

Thank you anyway for your reply. :)
Katy Cabral
Regular Collector

Re: Request with strange status behavior

Hi Lee,

I am on 5.5 also and i see this happen frequently. In my experience, if the system times out, or if the user saves the request before it is able to resolve to the current status, the request will remain in the prior step's status (although the action buttons at the top of the request will show otherwise). This causes a problem for us with portlets that capture certain statuses...Sorry this is not a solution, but just wanted you to know that you are not alone!
J. Yebusibí Lee
Occasional Contributor

Re: Request with strange status behavior

Thank you Katy, it's good to know that I'm not alone on this.
Cris Robin
Regular Collector

Re: Request with strange status behavior

Hello Lee

Sorry to inform you that i got the same strange behavior with version 7.1 sp2.

I think it happened when you got a very long form or a very long workflow.

If you having this problems and you do got a very long workflow, maybe it will help if you use sub-workflow to shorten the main workflow.

I sadly can't tell you if it will help.

Hope you will find it helpful

Sagi
J. Yebusibí Lee
Occasional Contributor

Re: Request with strange status behavior

Cris thank you for your comments.
//Add this to "OnDomLoad" event