Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Request type name, 'PFM - Proposal' not found.

SOLVED
Go to solution
Highlighted
M13
Regular Collector

Request type name, 'PFM - Proposal' not found.

Hi,

when i try to create a proposal in PPM 7.5, i get this error: Request type name, 'PFM - Proposal' not found.

I installed the upgrade package but the problem still persists.

Does anyone have any idea how can i solve this problem?? is there any best practices that need to be installed??, & where can i find it??

thanks in advance,
Ahmed
12 REPLIES
shygirl
Regular Collector

Re: Request type name, 'PFM - Proposal' not found.

Hi Ahmed,

You need to install the best practices. You just need to deploy it in the bin folder of your PPM fileysystem.

To install Best Practices:
1. Start the PPM Server.
2. Run the kDeploy.sh script, as follows:
sh kDeploy.sh -best-practices
M13
Regular Collector

Re: Request type name, 'PFM - Proposal' not found.

thank you, but can you give me the steps in full details, i would be grateful if you do that :)

and is there any alternative method to deploy the best practices other than running the script??
Mahen M
Honored Contributor
Solution

Re: Request type name, 'PFM - Proposal' not found.

To install Best Practices:
1. Log on to your Application Server through Remote Desktop connection if your Server is Windows.
2. Start the PPM Server by kStart.sh command, If your server already running, I hope this is not needed.
3. Open Cygwin or Command Prompt.
4. cd $ITG_HOME/bin ($ITG_HOME is the location where your PPM is installed)
5. Run the kDeploy.sh script, as follows:
sh kDeploy.sh -best-practices.

I have not tried this before but this is what shygirl had mentioned.


Regards,
Mahendran M
Mahen M
Honored Contributor

Re: Request type name, 'PFM - Proposal' not found.

It works and it requires the DB Password, Thanks.

Regards,
Mahendran M
M13
Regular Collector

Re: Request type name, 'PFM - Proposal' not found.

thanks a lot Mahendran for your concern, but unfortunately it didn't work, i followed the steps but i don't know where exactly the problem is!

i think may be the problem is with the kDeploy.sh file, i attached a screen shot of the errors i get when i try to run the script..

i will be grateful if you can provide further assistance. thanks for your time :)
Mahen M
Honored Contributor

Re: Request type name, 'PFM - Proposal' not found.

Check up your Java Home in the environment variables.

Check if the following command works from the same bin folder

'sh kRunCacheManager.sh A'

Check up whether the following file really exists in the following location

"/bin/jars/kntaconfig.jar"

In Server.CONF
Is there is a following line?
com.kintana.core.server.SERVER_TYPE_CODE=?

Regards,
Mahendran M
M13
Regular Collector

Re: Request type name, 'PFM - Proposal' not found.

Java home enviroment variables are already set, kntaconfig.jar exists, 'com.kintana.core.server.SERVER_TYPE_CODE=WINDOWS' is found in server.conf

sh kRunCacheManager.sh A returns the same errors .. screen shot attached.

i think there is a major flaw in the kVariables.sh file.

??
M13
Regular Collector

Re: Request type name, 'PFM - Proposal' not found.

i did some slight modifications in kVariables.sh & kRunCacheManager.sh where the errors exist (after taking a backup of both files of course), and another kind of error showed up. A screen shot is attached.
shygirl
Regular Collector

Re: Request type name, 'PFM - Proposal' not found.

Hi what is the version of java you are using?

You have to set your java_home in the environment variables of application server.
Mahen M
Honored Contributor

Re: Request type name, 'PFM - Proposal' not found.

Ahamed,
There is nothing wrong with the Shell scripts, I hope you are using Java 1.6, Please checkup whether 1.6 is supported in PPM, We use 1.4

Is your environment Clustered environment?

Root cause must be that characters in the files are not translated properly to unix format. This is due the difference in the line endings in windows and unix (cr/lf or lf) and is a known cygwin problem, probably a cygwin configuration or installation affects the sh files in PPM.

Run d2u *.sh command form the command prompt. This command searches recursively for all files with the ending ".sh" from the current directory and runs the command dos2unix (d2u) for all of these files separately. Then, the dos2unix command replaces all carriage returns with line feeds and the files are available again.

Regards,
Mahendran M
Jim Bowen
Super Collector

Re: Request type name, 'PFM - Proposal' not found.

A different thought...

Have you checked the workbench to see if the request type "PFM - Proposal" actually exists, and is enabled?

Jim
M13
Regular Collector

Re: Request type name, 'PFM - Proposal' not found.

Dear All,
Thanks a lot of for your concern & help.
I resolved the problem last week but i forgot to update the topic.

Solution:
Make sure that the path of the JAVA_HOME in the enviroment variables ends before the bin folder, i.e: "C:\Java\", NOT
"C:\Java\bin\" NEITHER "C:Java\bin\java.exe". The path should be as mentioned on the PPM server in order for the .sh script files to run properly.

PS.: Attached is PPM's post installation exercise doc from the essentials course that should be helpful also.
//Add this to "OnDomLoad" event