Project and Portfolio Management Practitioners Forum
cancel

Request type details are not shoiwng

Highlighted
PPMRam
Super Contributor.

Request type details are not shoiwng

Hi,

 

We are using PPM 8.0 SP2. We have cluster configuration with 4 servers. When we open create request page, sometimes, sections and fields within the sections are notdisplaying to users. Instead, the message ""there are no details....." is displaying ebethough there are sections for that request type exists. Can anyone tell me what could be the problem. Sometimes we are able to see all the sections and fields. but sometimes we are unable to see any details. Can anyone please give the solution ASAP.

 

Thanks

Shravan

8 REPLIES
Celil
Acclaimed Contributor.

Re: Request type details are not shoiwng

It looks like as communication problem between clusters in LAN. The communication get closed as whole data wouldn't send.

Celil
Celil

IT Governance Professional
& PPM Solution Architect
PPMRam
Super Contributor.

Re: Request type details are not shoiwng

Hi Celil,

 

Thanks or your response. How can we overcome this problem. Is there any setting that we need to do or Is there any way to solve this issue.

 

Thanks

Shravan

Celil
Acclaimed Contributor.

Re: Request type details are not shoiwng

Here are some important points in clustering about communication. Please check them on all cluster servers:

 

1) in server.conf...

 

  • APP_SERVER_MULTICAST_PORT: Check for is there a port conflict? All nodes in the cluster must use the same multicast port. Specify a value that is different than the value set for MULTICAST_PORT.
  • MULTICAST_PORT: Check for is there a port conflict? Because the cache communication occurs over a separate channel, the MULTICAST_PORT value in the server.conf file must be different than the MULTICAST_PORT value (46545) set in the PPM Center system cache.conf file. (more possible reason can be this)
  • MULTICAST_IP: Check for is there a IP conflict? The IP address must not include the text string “http://”. The MULTICAST_IP value in the server.conf file must be the same as the MULTICAST_IP value set in the PPM Center system cache.conf file.

2) please have a look PPMx.xx_InstallationAdmin.pdf page 175 configuration examples. page 185 sample port settings

 

3) Multicast must be enabled on network components such as network cards, switches, and routers. To avoid conflicts between cluster environments, consider the following:

  • Each server cluster environment must have MULTICAST_IP and MULTICAST_PORT values specified both in the server.conf file, and in the cache.conf file.
  • The IP address you specify for MULTICAST_IP must not include the text string “http://”.
  • All nodes in a cluster, must share the same MULTICAST_IP settings.
  • All nodes in a cluster, must use different MULTICAST_PORT values.
  • To ensure that the multicast port for the server cluster does not conflict with the multicast port used by JGroups, make sure that the MULTICAST_PORT parameter in the server.conf file is not sent to port 46545.
  • If more than one server cluster environment (for example, for Development, Test, and Production) is on the same network segment, you must specify unique values for the MULTICAST_IP and MULTICAST_PORT parameters in the server.conf file for each server cluster.
  • If multiple clusters use the same MULTICAST_PORT parameter values, the PPM Server(s) may not start up.
  • If clusters other than those related to PPM Center are set up, and these use the same multicast IP/port, the environment may also conflict.

4) If all above checks OK. Please run cluster servers with combination.(It's not good way)  example:

  • run PPM with server1,2,3
  • run PPM with server2,3,4
  • run PPM with server3,4,1
  • etc...

After all these checks, you still get same issue you should open case to HP. It's hard to find issue.

 

Celil

Celil

IT Governance Professional
& PPM Solution Architect
Jim Esler
Acclaimed Contributor.

Re: Request type details are not shoiwng

In order to quickly determine if all of the nodes in your cluster are communicating with each other, you can do the following:

 

1) Display the CacheManager Statistics report in the Workbench and verify that all nodes have entries in the various caches.

2) Clear the caches by executing 'sh kRunCacheManager.sh A'.

3) Refresh the CacheManager Statistics report and verify that all nodes have cleared their caches.

 

We have seen instances where a node has lost contact with the other nodes when more than one node was running on a physical server.

PPMRam
Super Contributor.

Re: Request type details are not shoiwng


Jim Esler wrote:

In order to quickly determine if all of the nodes in your cluster are communicating with each other, you can do the following:

 

1) Display the CacheManager Statistics report in the Workbench and verify that all nodes have entries in the various caches.

2) Clear the caches by executing 'sh kRunCacheManager.sh A'.

3) Refresh the CacheManager Statistics report and verify that all nodes have cleared their caches.

 

We have seen instances where a node has lost contact with the other nodes when more than one node was running on a physical server.



Hi Celil,

 

Please find the attached server.conf. Could you please check once and let us know any changes required.

 

Thanks.

PPMRam
Super Contributor.

Re: Request type details are not shoiwng

Hi Celil,

 

Please find the attached server.conf. Could you please check once and let us know any changes required.

 

Thanks.

PPMRam
Super Contributor.

Re: Request type details are not shoiwng

Hi Celil, Please find the attached server.conf. Could you please check once and let us know any changes required. Thanks.

Celil
Acclaimed Contributor.

Re: Request type details are not shoiwng

There are some notes about the server.conf parameters:

  • if not important for you change to false this parameter: ORACLE_APPS_ENABLED
  • Is your JDBC_URL definition same with oracle client tns definitions ?  (oracle client tns definitions location like: C:\app\Administrator\product\11.1.0\db_1\NETWORK\ADMIN  and  tnsnames.ora file )
  • for WORKBENCH_PLUGIN_VERSION=1.6.0_07 parameter. Is this information update. Please run java -version in command line, please check JAVA_HOME is correct in server.

I have some doubt about tns definition in JDBC_URL parameter. I couldn't beat the point about this topic because of that I don't know your system architecture and other details (oracle configurations etc)

It's too hard to see mistake in the big file. I did my best.

 

Celil

Celil

IT Governance Professional
& PPM Solution Architect