The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
The community will be in read-only from Monday 11:59pm (PT) to Wednesday 7:30am (PT)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Request status is not getting updated

Highlighted
ppm914
Super Collector

Request status is not getting updated

We have multiple different request types whose request status does not change from Not Submitted. The workflow moves ahead;but the request status does not get updated.

Please advise.

10 REPLIES
ppm914
Super Collector

Re: Request status is not getting updated

We are on 8.02

mike_se
New Member

Re: Request status is not getting updated

The Request's Status will be based off of the Workflow.

 

Check the Step Sequence in the Workflow. Check the Graphical View of the Workflow in the Status section to see the current Workflow Step.

 

May be the first Workflow Step is actually different than what is expected or the Status of that first Workflow Step is different than what is expected.

 

 

-Mike

 

PS: 8.02 has reached it's end of life, so will want to upgrade

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
mike_se
New Member

Re: Request status is not getting updated

And then if some Requests from the same Request Type work as expected, and then others do not, may have to look at what the differences are.

 

For example, may be the ones not acting as expected were created differently with the "Make Copy" button or something along these lines. Or may be the Requests were saved as a Draft.

 

If issue is only happening with Requests from a particluar Request Type/Workflow, then probably an issue with the Workflow configuration (as mentioned in last post).

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
ppm914
Super Collector

Re: Request status is not getting updated

This issue does not seem to be related to configuration as it does not occur for all requests; Just for couple of requests where the workflow does not set the request status and status remains unchanged as "Not Submitted"

mike_se
New Member

Re: Request status is not getting updated

There must be a difference between a Request that moves forward as expected and one that does not. Difficult to say what exactly could cause the issue. Nothing exactly like this reported previously in the Support Database.

 

May be an Execution Step is the first step and it is failing or it is not done processing.

 

To narrow it down further:

1) Create a new Workflow that starts with a Decision Step, and new Request Type to create Requests, see if can reproduce the issue

2) Check the serverLog.txt and/or Workflow Execution Step logs for any errors

 

-Mike

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
Jim Esler
Honored Contributor

Re: Request status is not getting updated

You say this is happening "Just for couple of requests where the workflow does not set the request status and status remains unchanged as 'Not Submitted'". This is the behavior I would expect. A request's status is 'Not Submitted' until it is changed by a workflow step that has a different status specified.

Erik Cole
Honored Contributor

Re: Request status is not getting updated

You might verify that the requests in question are actually in the right workflow. There is an issue where requests occasionally do not get submitted to the correct workflow...that might cause a similar symptom....

vinay252
Acclaimed Contributor

Re: Request status is not getting updated

Hi,

Is this issue solved? 

We are facing the same problem. Request moves to the Next Step in the workflow, But the status does not change from "NOT SUBMITTED" . Only Observation is this happens only when user saves the Request as a draft and then submits later. And not everytime in this scenario as well.

 

Thanks,
Vinay

Rich Y_1
Member

Re: Request status is not getting updated

Vinay,

I saw this issue many times in 9.14 but since moving to 9.32 it seems to have mostly if not totally gone away.  I never could figure out the cause and HP was not able to either.  In 9.14 sometimes a request would move from one step to another advancing the status and another request would not.  Did not happen all the time but was several times a month.  I was seeing enough that I created a Portlet to monitor all our requests and alert me to those that did not change.  Then I was able to correct the issue..  But like I said it seems like moving to 9.32 helped out as I don't remember the last time I saw this.

Aurobinda
Super Collector

Re: Request status is not getting updated

HI,

r already answered this. Please make sure there is a request status mentioned in the workflow step for which you are expecting the status should be changed once the request moved to this step, from the first step.

//Add this to "OnDomLoad" event