The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Request Type Buttons not working

Highlighted
mallik_248
Super Collector

Request Type Buttons not working

Greetings,

HP PPM version 9.22 running on Linux

We create a Custom Request using a pl/sql procedure which updates the kcrt_request_details_int and kcrt_requests_int tables and then runs the kcrt_request_int.run_interface.

While the request gets created without any issues with all the data that we pass, the buttons fail to work. Clicking on the action buttons + Cancel button does nothing. I can see a grey rectangular border around the buttons which I think is due to this issue. (attaching the screenshot).

Also, note that the issue is only with the requests that are getting created using the custom procedure from the background. Rest of the request types have no issues whatsoever!

What are we missing here? Any inputs are greatly appreciated.

Thanks,

Arjun

 

4 REPLIES
PM0partners
Occasional Advisor

Re: Request Type Buttons not working

Hi,

The step in which the workflow has failed, is an executable step? Have any error in link "Trasition Details"?

I ask you these questions because to see your screen shot, seems to be an error after it is performed an executed step.

Regards.

mallik_248
Super Collector

Re: Request Type Buttons not working

Hello,

 

That is correct. We ahve an execution step in the very buginnning of the Request Workflow that creates a child package.

If I remove this execution step and create a request, the buttons work just fine. 

How are we creating the child package:

We are creating the child package using a custom pl/sql procedure which feeds the KDLV_PACKAGE_INT & KDLV_PACKAGE_LINES_INT tables and then runs the interface report thus creating the package.

What is that we are missing here?

 

Thanks,

Arjun

Derek Giedd
Frequent Visitor

Re: Request Type Buttons not working

You are seeing the override buttons because the user you are logged in as is on the step security for the Bi-Weekly Package Workflow step.  Can you post your workflow and the contents of the Execution step?

-- Remember to give Kudos to answers! (click the KUDOS star)
Neha-Sharma
Acclaimed Contributor

Re: Request Type Buttons not working

Hi, 

For The solution, i Understood that the execution step is the first step in your Workflow. 

Try Adding Or step before the execution Step, i.e. The Or step as first step of workflow. 

Let me know if this works for you. 

-- Remember to give Kudos to answers! (click the KUDOS star)

Thanks

Neha

//Add this to "OnDomLoad" event