Project and Portfolio Management Practitioners Forum
cancel

Request Rules not working in PPM 7.5 SP1

Highlighted
Donna McClung
Contributor.

Request Rules not working in PPM 7.5 SP1

We just upgraded to 7.5 SP1. I have rules set up to change the "assigned to" field when the "application" field changes. I create the request, the default assigned to works, I go to application field, change it, but the assigned to doesn't work. The rule is set to run on "field change". Has anyone else experienced this?
5 REPLIES
Jim Esler
Acclaimed Contributor.

Re: Request Rules not working in PPM 7.5 SP1

We noticed that 7.5 SP3 processes rules with "Apply on field change and stop processing rules" differently than earlier releases (7.1 and 6.0). In 7.5, rule processing stops when a dependent field changes, regardless of its value. In earlier releases, rule processing stopped only if a dependent field was changed TO A SPECIFIED VALUE. Your rule processing may possibly be stopped by an earlier rule if you are using this option on the earlier rule.

We have submitted a Case to HP asking if this chagne was intentional or is a defect. It seems like the change would break a lot of existing logic and rewriting the rules to cope with it could be very painful. I see no use for the option in its current incarnation.
Donna McClung
Contributor.

Re: Request Rules not working in PPM 7.5 SP1

Thanks for the response. I had it set to stop processing from our 6.0 version. I changed to to continue processing rules to see if that would fix it but it didn't. If you find out anything from HP, I would be very greatful if you could post it here.
Marlene Mazzeo
Super Contributor.

Re: Request Rules not working in PPM 7.5 SP1

We are using 7.5 SP3, and our rules seem to be working correctly. We use the "on field change" rule with the Application field that then sets another field in the Details section based on Application.
Devin Rosenbaue
Frequent Contributor.

Re: Request Rules not working in PPM 7.5 SP1

Does the rule also depend on a table component or a multi-line text field? Do any other rules depend on the "Application" field which tell PPM to stop processing rules?

There are some issues with those in PPM 7.5. I already provided HP with a fix during our support case, which I assume we'll see in some future service pack.
Donna McClung
Contributor.

Re: Request Rules not working in PPM 7.5 SP1

There are other rules but I have the continue processing rules set to yes. There is no multi line anything. A very simple rule, when a request opens, default the assigned to to one person, when the application field is changed (all the other rules) change the assigned to based on the application field. Thanks for your response.