Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Request Creation Fails

SOLVED
Go to solution
Highlighted
EngPlan
Member

Request Creation Fails

I have a workflow step command that is supposed to create a request when a certain workflow step is initiated.  My command looks like this:

 

ksc_create_request FROM_REQUEST_ID="[REQ.REQUEST_ID]", REQUEST_TYPE_ID="30670" COPY_FIELDS="Y" COPY_NOTES="N" CREATE_REFERENCE="Y" REF_RELATIONSHIP_ID="16" SUBMIT="Y" WORKFLOW_ID="30928"

 

So, a couple things here.  I realize that I am calling out a specific request type to be created and workflow to be used.  This command previously worked and how it "broke" I do not know.  When I get to the workflow cstep that initiates the creation of the new child request, the timeclock starts, completes and there is no reference request made/attached to the original request.

 

I have tried interchanging the ksc_create_request with ksc_copy_request and this does not work either.

 

My execution step is using this validation: WF - Standard Execution Results

My processing type is Immediate

My execution step is enabled

and my timeout is set at 90 seconds

 

Attached is the Transaction Log for the request.

 

Thanks in advance for any suggestions or assistance.

12 REPLIES
AlexSavencu
Honored Contributor

Re: Request Creation Fails

Hi, engplan,

 

check the following:

- under KINTANA_HOME/logs/REQ_XXXXX you should be able to find the logs of the command execution;

- double check that the RT ID and the WF ID actually match the ones you're interested in;

- triple check what has changed right before the command started failing.

 

cheers

alex


--remember to kudos people who helped solve your problem
EngPlan
Member

Re: Request Creation Fails

Thanks for the quick response Alex.  here is the error the log gives:

 

VALIDATION_NAME=
Exception occured during execution: KCRT_REQUEST_UTIL-Request(31963) import failed with ORA-01407: cannot update ("PPMUSER"."KCRT_FG_PFM_PROPOSAL"."PROPOSAL_NAME") to NULL {KCRT_IMPORT_FIELD_GROUPS_INT-10050}

 

AlexSavencu
Honored Contributor

Re: Request Creation Fails

Hi, engplan,

 

it should be quite obvious: there is a problem with the PROPOSAL_NAME field.

 

Check if the field is populated in the source request.

 

cheers

alex


--remember to kudos people who helped solve your problem
EngPlan
Member

Re: Request Creation Fails

So I went back to the original request type and ensured there was a "Proposal Name" field.  When I run it now it gives off this error:

 

An error occurred during command parsing.
 (KNTA-10127)
GUID=CD413520-E69E-A212-D1C5-4D63A9C960B7 Unknown or out of sequence command:
[ksc_create_request FROM_REQUEST_ID="31935", REQUEST_TYPE_ID="30670" COPY_FIELDS="Y" COPY_NOTES="N" CREATE_REFERENCE="Y" REF_RELATIONSHIP_ID="16" SUBMIT="Y" WORKFLOW_ID="30928"]

Erik Cole
Honored Contributor

Re: Request Creation Fails

In your list of parameters you have a comma right before REQUEST_TYPE_ID

 

Try removing that...

EngPlan
Member

Re: Request Creation Fails

 

Erik, thanks for the suggestion.  Unfortunately, it gives off the same error:

 

An error occurred during command parsing.
 (KNTA-10127)
GUID=C20CDF65-72EA-D3A6-68B7-DD5EF970579C Unknown or out of sequence command:
[ksc_create_request FROM_REQUEST_ID="31937" REQUEST_TYPE_ID="30670" COPY_FIELDS="Y" COPY_NOTES="N" CREATE_REFERENCE="Y" REF_RELATIONSHIP_ID="16" SUBMIT="Y" WORKFLOW_ID="30928"]

Erik Cole
Honored Contributor

Re: Request Creation Fails

Unless you created your own, there is no ksc_create_request

 

Try using ksc_copy_request

EngPlan
Member

Re: Request Creation Fails

Right...got it.  Thought I'd changed it back to 'copy'.  Now the response is as expected, but I am back to my original error:

 

VALIDATION_NAME=
Exception occured during execution: KCRT_REQUEST_UTIL-Request(31965) import failed with ORA-01407: cannot update ("PPMUSER"."KCRT_FG_PFM_PROPOSAL"."PROPOSAL_NAME") to NULL {KCRT_IMPORT_FIELD_GROUPS_INT-10050}

 

I'm certain that Alex is correct, I am having a very hard time tracking down how to ensure that the fields are the same between requests since we have customized the different requests....

Erik Cole
Honored Contributor

Re: Request Creation Fails

Yeah, it looks like you're tyring to create a proposal. Are you copying it from an existing proposal, or project? If so, KCRT_FG_PFM_PROPOSAL.PROPOSAL_NAME maps to the field in your header with the token KNTA_PROJECT_NAME.

EngPlan
Member
Solution

Re: Request Creation Fails

Solved!  Thanks to everyone who helped.  I went back to the original request header, added the field group for PFM Proposal and this allowed the workflow to create the request correctly.  Thanks again for your assistance.

AlexSavencu
Honored Contributor

Re: Request Creation Fails

Congratulations! I believe kudos are in order...

Cheers
Alex

--remember to kudos people who helped solve your problem
gatienza
Occasional Contributor

Re: Request Creation Fails

Hello, we have a problem when the execution of comand ksc_copy_request generate an error.  We need read the return code of command ksc_copy_request and if the code is 0 show a Message and act consequently.

 

It is possible? Thanks in advanced

 


//Add this to "OnDomLoad" event