The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Project overview portlet donâ t working fine

SOLVED
Go to solution
Highlighted
Semenov Alexand
Esteemed Contributor

Project overview portlet donâ t working fine

Good day.
I try create Project overview portlet (ppmc 7.5 sp 5) but this portlet donâ t working fine i.e. this portlet stored data from 1-t project overview page.
All add please see in attach.
Thanks in advice.
9 REPLIES
Erik Cole
Honored Contributor

Re: Project overview portlet donâ t working fine

Looks like you have it set right. Only difference I see in what I have here is I have Entity_Key filter in the data source set as Required.
Semenov Alexand
Esteemed Contributor

Re: Project overview portlet donâ t working fine

Erik thanks, but Required not help me.
Have you any ideas?
ljokirk
Member

Re: Project overview portlet donâ t working fine

Hi,
We also did something similar to what Eric did. We have Entity_Key filter in the data source set as Required and have it with default set to zero. See attached.

Another issue I ran into was existing projects weren't picking up this field correctly. We ran a query to determine the Entity_Key values for these projects.
Next, we populated this field in the portlet preferences for each existing. Volume was not a problem to do this manually.

In order to update Entity_Key field, we had to 'unlock' the Project Overview Layout Project Settings and set "Allow Project Manager to Override these settings" to yes for the Project Overview Layout section of the Project Type.

I got the info from the following thread (which Eric helped with) - Project Overview custom portlet at http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1296127.

Lisa
Semenov Alexand
Esteemed Contributor

Re: Project overview portlet donâ t working fine

Lisa Thanks!
But we don't wont to 'unlock' the Project Overview Layout Project Settings.We need do this for all projects automaticly.
How can i do this in this case?
Thanks.
ljokirk
Member

Re: Project overview portlet donâ t working fine

We didn't want to unlock it either. Based on the info I read in the thread I provided, we had to. Otherwise, it prevented the token from evaluating in the portlet that was added.

We have a small group of PLs (< 15) so we decided it was worth the risk to open it up. Unfortunately, I don't know of any other way to handle this than what we did. It's been working fine.
ljokirk
Member

Re: Project overview portlet donâ t working fine

To make sure this was clear...the field was populated automatically for new projects. We only did manual intervention on the existings on.
Semenov Alexand
Esteemed Contributor

Re: Project overview portlet donâ t working fine

Lisa Thanks!
But still not working.
Can you send (ASSemenov@sberbank.ru)/see for me your DS SQL/setting and portlet settind.
Many thanks!!!
ljokirk
Member
Solution

Re: Project overview portlet donâ t working fine

Hello,
Sorry for the delay. I sent email but didn't hear back from you. I needed to wait until forum was available to post. The DS and settings are attached.

Lisa
Semenov Alexand
Esteemed Contributor

Re: Project overview portlet donâ t working fine

Lisa,thanks. I have similar settings :-)
//Add this to "OnDomLoad" event