Project and Portfolio Management Practitioners Forum
cancel

Problem in Generating Reports.

Highlighted
Mahen M
Acclaimed Contributor.

Problem in Generating Reports.

Hi,
I am having problems in generating 'Request Type Detail Report' in our QA environment. THe execution fails, I have attached the snap of the error, Kindly have a look and advice what may be the cause of this error.

Regards,
Mahendran M
6 REPLIES
Volker Schoettn
Honored Contributor.

Re: Problem in Generating Reports.

Hi,

However copy the line after "Create Process" to a command line box on your ppm server execute it and see what happens there.

I'm not able to see the whole message. Can you copy the whole message from the report output to the thread, maybe with debugging details?

Thank you

Regards
Volker
Mahen M
Acclaimed Contributor.

Re: Problem in Generating Reports.

Hi,
I do not have access to Application Servers.

Please find the log


CL Local Exec

Source Command: Run Report

D:/oracle/ora92/bin/sqlplus.exe PRODPITG/#!#*****#!#@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=xsd00y15)(PORT=1522)))(CONNECT_DATA=(SERVICE_NAME=orayev0g))) @./scripts/kcrtrpt_request_type_detail_help '\\WSOMDAVITG03\D$\ProdApps\ITG\reports\' 'rep_164572' 'PER - Work Item Project Request' 'PER - Work Item Project Request' 'Y' 'Y' 'Y' 'Y' 'Y' 'Y' 'Y' 'Y' 'Y' 'Y'

Error creating Process.

CreateProcess: D:/oracle/ora92/bin/sqlplus.exe PRODPITG/circusdog1@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=xsd00y15)(PORT=1522)))(CONNECT_DATA=(SERVICE_NAME=orayev0g))) @./scripts/kcrtrpt_request_type_detail_help \\WSOMDAVITG03\D$\ProdApps\ITG\reports\ rep_164572 "PER - Work Item Project Request" "PER - Work Item Project Request" Y Y Y Y Y Y Y Y Y Y error=3


Thanks

Regards,
Mahendran M
Volker Schoettn
Honored Contributor.

Re: Problem in Generating Reports.

Hi,

take a closer look around this part:
\\WSOMDAVITG03\D$\ProdApps\ITG\reports\ rep_164572

1.) Do this share exist?
2.) Do the PPM service user have write permission on this share?
3.) There is a space between the directory part of the share and the file name.

It seems to be a configuration problem of your REPORT_LOG_DIR.

Run the Server Configuration Report located in the "SysAdmin Server Tools" Workbench and check com.kintana.core.server.REPORT_LOG_DIR

Maybe is just a typo in server.conf

Find somebody with admin rights on the App Server.
Advise him to backup the server.conf and run dos2unix server.conf (It doesn't matter if it is a windows box)
after this run "sh kUpdateHtml.sh" located in the bin dir.

If this do not solve, than modify the server.conf (use wordpad or kConfig.sh instead of notepad)to set the REPORT_LOG_DIR to a local dir rather than a share.
Don't forget kUpdateHtml.sh (only needed when you modify the server.conf with a editor) after modifing the server.conf.

Regards
Volker
Mahen M
Acclaimed Contributor.

Re: Problem in Generating Reports.

Hi Volker,
I think you have caught the issue. I ran the Server Configuration Report.

com.kintana.core.server.REPORT_DIR \\WSOMDAVITG03\D$\ProdApps\ITG\reports\

com.kintana.core.server.REPORT_LOG_DIR \\WSOMDAVITG0\D$\ProdApps\ITG\logs\reports\


Can you kindly advice me on your Question 'There is a space between the directory part of the share and the file name.'

Are you sure that the correct location is the one present in 'com.kintana.core.server.REPORT_LOG_DIR' line.

Is it not 'com.kintana.core.server.REPORT_DIR'

Is this setting should be mapped in Server.Conf? Is that Setting looks like
'com.kintana.core.server.REPORT_DIR=//WSOMDAVITG01/D$/ProdApps/ITG/reports'?(Taken from DEV Environment, I have access to it)

Please advice on these lines.

Regards,
Mahendran M
Mahen M
Acclaimed Contributor.

Re: Problem in Generating Reports.

Hi Volker,
I have a look into the successful Reports. I do see the log as below


D:/oracle/ora102/bin/sqlplus.exe PRODPITG/#!#*****#!#@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=xsd00y15)(PORT=1522)))(CONNECT_DATA=(SERVICE_NAME=orayev0g))) @./scripts/kcrtrpt_request_type_detail_help '\\WSOMDAVITG03\D$\ProdApps\ITG\reports\' 'rep_163261' 'PER - PPLC Project Request' 'PER - PPLC Project Request' 'Y' 'Y' 'Y' 'Y' 'Y' 'Y' 'Y' 'Y' 'Y' 'Y'


I think '\\WSOMDAVITG03\D$\ProdApps\ITG\reports\ rep_164572' is not a share. I Application Server Admin told me '\\WSOMDAVITG03\D$\ProdApps\ITG\reports\ rep_164572' Does not exist.

Please advice whether I still need to request for the workaround which you have mentioned.

Thanks in Advance for your Help.

Regards,
Mahendran M
Volker Schoettn
Honored Contributor.

Re: Problem in Generating Reports.

Hi,

is this a clustered env?
In this case the share makes sence, and should not be changed.

Otherwise:
Per default is the REPORT_LOG_DIR not included in the server.conf but you can add it.
com.kintana.core.server.REPORT_LOG_DIR=
com.kintana.core.server.REPORT_DIR=

In this case: run kUpdateHtml.sh and bounce the server.

Then check the parameter with the Server Configuration report again.

Use a local path like D:\ProdApps\ITG\logs\reports\ (or / I'm not sure)
Check if the ppm service user have write access to the reports dir and reports log dir.

When it is a cluster than take into account that the $-Share can only be used by members of the local administrator group.
Check if the ppm service use the local system account. As far as I know this account can't access Shares....

Hope it helps.

Regards
Volker