Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Previous Time Periods to Show Limitation

Highlighted
estech
Acclaimed Contributor

Previous Time Periods to Show Limitation

I need change the maximum number of Previous Periods to Show in Approve Time portlet, under the menu Time Management\Time Sheets. I made changes in server.conf adding the value com.kintana.core.server.TMG_PAST_PERIODS_TO_ALLOW=30 and executing command kUpdateHtml after the change.
It seems to be other validation that prevent introducing a number higher than 12.

PPM version 7.1

A screeshot is attached.

Thanks.
7 REPLIES
Darshan Bavisi
Occasional Visitor

Re: Previous Time Periods to Show Limitation

Hi,

The server parameters for changing the past and future time periods is only for creating time sheets. The Approve Time Sheet portlet is a Java portlet so it can't be modified also. You may have to create a custom similar portlet for that.
vamsee_1
Regular Collector

Re: Previous Time Periods to Show Limitation

Hey,

Even we have been trying for the same and there is no way other than chaning the JSP Page for this portlet that you can get what you desired.

Another way could be by giving a custom portlet which shows any of the time sheets pending for approval and then approving those time sheets by a tedious way from the main menu : Time ---> Approve Time Sheets and then entering the required fields.

You can definitely change the validation for the Approve Time sheets page by changin the sql validation from the backend in knta_validations table.

Hope this helps.
estech
Acclaimed Contributor

Re: Previous Time Periods to Show Limitation

Hi,

Thanks in advice for the support.
I have change the "TMG - Numeric Field (0 - 12)" validation in order to set parameter1 and visible_parameter1 to 20 in the knta_validations table. After this change I have verify in the workbench that the change has been commited, a cache flush has been done. In the button "Used by" it references only to Reports Types "Delinquent Time Sheets" and "(REFERENCE) Delinquent Time Sheets" but Approve Time portlet doesn't appears.
The validation for "Previous Time Periods to Show" stills having 12 as maximum value in portlet Approve Time.
Any idea?
Ahmed_M
Acclaimed Contributor

Re: Previous Time Periods to Show Limitation

Hi,

 

My need is almost the same as we wish to increase the number of "previous periods" in the "Approve Time" standard search.

By changing the parameter TM_MAX_PREVIOUS_TIME_PERIODS to 52 we already can see that the available values have increased.

However, when we click on search, we have another "Warning screen" that prevent us from using this change (screenshot attached). 

 

I saw in the previous answer that we should change the validation “TMG - Numeric Field (0 – 12)” from the backend. Unfortunatly we did not get any results. 

 

Could you please help us for this matter?

 

Thank you in advance.

 

Best Regards,

Hp PPM
Super Collector

Re: Previous Time Periods to Show Limitation

 

Knta_validations is view. Parent table is  KNTA_VALIDATIONS_NLS. Updating this table with last update and entity update to sysdate willl reflect changes in 'tmg - numeric field 12' validation.

 

 

 

I tested this in 9.14 and it works for "Delinquent Time Sheets" report but it does not reflect in portlet 'Approve Time sheets'.

 

Looks like field name is same for report and portlet but used different validations.

"Previous Time Periods to Show"

 

 

Utkarsh_Mishra
Honored Contributor

Re: Previous Time Periods to Show Limitation

In version 9.x we have a paramter to increase it


TM_MAX_PREVIOUS_TIME_PERIODS

You need to check if it exists in your version.
Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
Hp PPM
Super Collector

Re: Previous Time Periods to Show Limitation

I tried that. It does not work.

 

Solution to this is custome code change in validation_tm.xml file

located under /deploy/itg.war/WEB-INF

 

Please change line 316 from 12 to 52:

 

                <var-value>12</var-value>

 

Then, run kUpdateHTML.sh and restart PPM.

//Add this to "OnDomLoad" event