Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Portlet Issue

Highlighted
Jyotir ++
Member

Portlet Issue

Hi ,

I am facing strange issue in PPM.I have a query which is running in 1-2 second from DB .But when I use same query in Portlet Datasource its taking even more than 20 Seconds.

I am not sure, why this happening.I am using Same query without any filter.

Please suggest if i m missing any thing.

-Jyotir
9 REPLIES
Sascha Mohr
Esteemed Contributor

Re: Portlet Issue

Hi Jyotir,
does the query contain a line like this?
AND kcrt_participant_check.can_user_view_request(request_id, [SYS.USER_ID] ) != 0
This check can take ages, especially if you are not an admin.
Niraj Prabhu
Frequent Visitor

Re: Portlet Issue

Jyotir,

Is there any Custom or OOTB tokens in the query? Try to force a errorneous Query thru portlet to see which query is getting executed. You can introduce a comma to get a syntax error.

Regards,
Niraj
Niraj P.

Re: Portlet Issue

Do you have a "order by" clause in your query? If so, try removing the "order by" clause and re-run.

It would be helpful if you can show us the query you are trying to run.

- Nisha
Jyotir ++
Member

Re: Portlet Issue

Thanks guys for your quick responses.

Sascha,

there is no as such check in Data Source query.
Just simple condition : USER_ID=[SYS.USER_ID], shich should be fine i guess.

Nisha,

I am not using Order by in Data source query, but as you PPM do sort it self...So its done by PPM.

Niraj,

No OOTB Token.

Thanks again for your respsponse.
Erik Cole
Honored Contributor

Re: Portlet Issue

Is this is list portlet, or is it producing some graphics and/or graphs?

Re: Portlet Issue

Can you share the query you are using.
Jyotir ++
Member

Re: Portlet Issue

Hi Erik,

Its List portlet.

-Jyotir
Sascha Mohr
Esteemed Contributor

Re: Portlet Issue

It will always take a little longer in a portlet compared to running the query on the database, PPM has to generate some HTML too, but factor 10.
It's only a single portlet on the dashboard page? Do the list entries contain HTML/graphic sources in a column? Maybe many drilldown links in several columns?
James++
Regular Collector

Re: Portlet Issue

Hi Jyotir,

If you are using any UNION in Sql code, then definitely it will take some time.

I had faced the same issue, the work around would be to create a View with that as per the requirement and fetch the data from that view.
This worked for me. I hope this may also work for you.
//Add this to "OnDomLoad" event