Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Pie Chart Not Showing % Values

Highlighted
Emir Gocen
Super Collector

Pie Chart Not Showing % Values

Hi,

All of a sudden the pie charts that use the default "request summary pie chart" portlet on our production environment have started not to show % values around the graph. Tooltip source works fine but % values do not exist.

Thanks in advance.

Emir
3 REPLIES
Jim Esler
Honored Contributor

Re: Pie Chart Not Showing % Values

I see this kind of behavior with bar charts, too. The tags stop appearing for a few days, then they reappear for a while. Tooltip continues to work, same as what you are seeing. Obviously, there is a flaw in the code and it has been this way for a long time. Open a case with HP but it probably will not get very high priority.
Emir Gocen
Super Collector

Re: Pie Chart Not Showing % Values

Hi,

Indeed you are right, it is happening in the bar charts as well. As far as I have dug into the depths of PPM, it is not quite possible for me to modify this tag - it is probably related to the rendering method PPM uses to generate the png files created for these portlets. I did open a case, but did not get any response. Hoping to get the tags back with my fingers crossed. :)

Thanks.

Emir
Emir Gocen
Super Collector

Re: Pie Chart Not Showing % Values

Hi,

When I used kSupport command I recieved this error:

server:AWT-EventQueue-0:SystemErr:2010/05/13-13:41:01.760 EEST: .
server:AWT-EventQueue-0:SystemErr:2010/05/13-13:41:01.760 EEST: cannot create bean of class com.kintana.core.web.chart.PieLabelAnnotation(labelRenderer) for pieAnnotation. Exception: java.lang.IllegalArgumentException: argument type mismatch
server:AWT-EventQueue-0:SystemErr:2010/05/13-13:41:01.760 EEST: May 13, 2010 1:41:01 PM ilog.views.util.css.IlvCSSBeans a
SEVERE: Could not create instance of class 'com.kintana.core.web.chart.PieLabelAnnotation(labelRenderer)' (rule chartRenderer).

Emir
//Add this to "OnDomLoad" event