The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

PPM9.13 & Attachments

SOLVED
Go to solution
Highlighted
AlanMarch
Super Collector

PPM9.13 & Attachments

Hello everyone,

 

Has anyone had any problems with attachments after upgrading to 9.13.  We went from 7.5 to 9.13 and now our attachemnts are not going where we specify.   When I open the config utility it does propopulate with the correct value of E:/attachments.  In fact my server.conf also reflect "com.kintana.core.server.ATTACHMENT_DIRNAME=E:/attachments".  However, attachment are being uploaded to "C:\PPM\attachments"

 

Has anyone had this problem?  Does anyone know how to fix this?

 

Thanks!

Alan

6 REPLIES
cotocald
Regular Collector

Re: PPM9.13 & Attachments

Hi, 

Try changing the directory to E:\ instead of E:/...

Also, point the paths on KNTA_APP_SERVER_PROPERTIES to the right path.

 

Regards

-- Remember to give Kudos to answers! (click the KUDOS star)
EstebanCabrera
Acclaimed Contributor

Re: PPM9.13 & Attachments

Hi Alan,

 

PPM scans all parameters in server.conf and the last value of ATTACHMENT_DIRNAME is set to dms.filesys.attachmentDir for dms.conf even if there are more than one ATTACHMENT_DIRNAME in server.conf.

Check what is the value of dms.filesys.attachmentDir in dms.conf file on every node in the cluster.

If there are any inconsistencies, try the following workaround:

 

1. Stop all PPM nodes

2. Edit server.conf to have the ATTACHMENT_DIRNAME in all the @nodes sections.

3. Copy over the same server.conf to all PPM servers.

4. Run kUpdateHtml.sh on all PPM servers.

5. Delete all the content of the following folders on each node:

PPM_HOME/server/SERVER_NAME/tmp

and

PPM_HOME/server/SERVER_NAME/work

6. Start all PPM nodes

 

Check if that helps

 

Thanks,

Esteban

Adsoto
Occasional Contributor

Re: PPM9.13 & Attachments

Hello Alan,

 

- If this is cluster, parameter ATTACHMENT_DIRNAME should be the same for all node in the cluster.

- After change something in the server.conf, run the script /bin/kUpdateHtml.sh, delete tmp and work files for every node and re-start the PPM application server.

- This directory must give read/write access to Web browsers. Check to see if there are file/directory level permission that is preventing access to directory.

- If the system includes an external Web server, exist outside the directory tree.

 

An example of a correct path:  C:/ppm/eon/attachments

 

Regards,

Adrian

If you find that this post resolves your issue, please be sure to mark it as an accepted solution. Please give me kudos if the information is useful.
Etienne_Canaud
HPE Expert

Re: PPM9.13 & Attachments

Hi All,

 

I don't think that the previous comments on how to update the attachment locations are entirely accurate since PPM version 9.13.

 

Since PPM 9.13, dms.conf contents are ignored (they are read only once during the first PPM Server startup just after upgrade, and stored in the Database). Once the dms parameters are in the database, the contents of dms.conf won't ever be read, and the kConfig tools shouldn't be used to configure DMS.

 

In PPM 9.13, in order to update your DMS parameters, simply go to the admin console, click on "DMS Configuration" menu (In "administration tasks"), update the parameters (for File System DMS, it's only the attachment folder), and save. The config will be automatically propagated to all PPM nodes if you are in clustered configuration, and no PPM Server restart is required.

 

Note that detailed steps are described in the 9.13 release notes.

 

Also, you may want to be very careful when updating the attachment folder directly in the DMS config screen (or in dms.conf for previous PPM versions): If you haven't copied all the attachment files to the new folder, all the previous attachments will be lost; moreover, if some user add some attachments between the moment you copied the files, and the moment you change the parameter value, this attachment will be lost too.

 

Thanks,

Etienne.

dirkf
Honored Contributor

Re: PPM9.13 & Attachments

Hi all,

 

there is a known issue with the dms.conf under certain circumstances.

Alan, first issue is to make known if this is a cluster setup.

If YES, then check if this issue of attachments going to the wrong location only occurs for certain users on certain nodes while from the primary user node, the attachments are going to the correct location.

if YES, then check if the physical directory structure of the nodes where the error is occuring was copied over from the primary node.

If again YES, you'll find that if you edit the dms.conf, after every run of kUpdateHtml.sh, it is reset to the default value. this is a known issue.

 

RnD states recently that the following should be done in respect to attachment-folder location in server.conf:

 

"We must specify ATTACHMENT_DIRNAME in each and every @node."

 

The solution for this defect in future will be that PPM scans all parameters in the server.conf and the last ATTACHMENT_DIRNAME is valid even if there are more than one ATTACHMENT_DIRNAME in server.conf.

 

Please see also QCCR1L44782 "When having seconary machine in cluster, dms.conf file has non-shared directory"

 

The defect is visible using the following link:

http://support.openview.hp.com/selfsolve/document/FID/DOCUMENTUM_QCCR1L44782

 

Does this in any way help?

 

Best regards,

Dirk

 

- Kudos always welcome -

AlanMarch
Super Collector
Solution

Re: PPM9.13 & Attachments

Hello,

 

Thank you everyone for your feedback I appreciate the help and support of this community .  I thought there were plenty of good ideas here to resolve my issue.  However, I'm sorry to say that none of them worked.  So the short story is I had to create an SR with HP and their suggestion that corrected my problem is pasted below.


Thank you everybody,

Alan

 

  • Hello Alan,

    The default is generally "C:\PPM\attachments". However, if you want to store the attachments in a different drive or server. We have an article that specifies these steps.

    KM195741
    How to divert attachments from the current location to a different directory or drive

    http://support.openview.hp.com/selfsolve/document/KM195741

    For Windows: Do not use the mounted drive letter, i.e. d:/kintana. Instead use the UNC, Universal Naming Convention, format to access the directory on the shared server. Switch \ to / in server.conf file. Ex. \\192.45.78.10\d$\kintana. This is due to the way window services work. Make sure to use forward slash instead of backslashes

    From kConfig.sh or from the server.conf, please change the parameter:

    From
    com.kintana.core.server.ATTACHMENT_DIRNAME=E:/attachments

    To
    com.kintana.core.server.ATTACHMENT_DIRNAME=\\192.45.78.10\E$\attachments

    Substitute the 192.45.78.10 for your server IP address and also make sure that the PPM user has Full access under this directory E:/attachments
  • This quote in the article is not right: Make sure to use forward slash instead of backslashes
    It should be, Make sure to use backslashes instead of forward slash....

    But still, the same plan:

    From kConfig.sh or from the server.conf, please change the parameter:

    From
    com.kintana.core.server.ATTACHMENT_DIRNAME=E:/attachments

    To
    com.kintana.core.server.ATTACHMENT_DIRNAME=\\192.45.78.10\E$\attachments

    Substitute the 192.45.78.10 for your server IP address and also make sure that the PPM user has Full access under this directory E:/attachments

    Remember to run kUpdateHtml.sh for any server.conf change
//Add this to "OnDomLoad" event