Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

PPM Workbench Error

SOLVED
Go to solution
Highlighted
michael.gregory
Esteemed Contributor

PPM Workbench Error

Hello,
We have installed PPM 8 on a test server (Windows 2008, 64-bit) and can access both the workbench and workbench (desktop) from the machine running the PPM application.

When I attempt to open remotely from my machine I get java errors in IE and a Kintana connection error in Firefox. I have no issues accessing the dashboard in either browser.

I have tried everything I can find related to workbench errors. I have uninstalled all java related software and reinstalled only the JRE that workbench installs on first access (6 update 7). Java temp files have been cleared. I have tried upgrading my browser from IE7 to IE8 but no change.

Java etc always downloads fine.

server.conf did not contain an entry for com.kintana.core.server.WORKBENCH_PLUGIN_VERSION=1.6.0_07 so I tried adding that in, restarted the server, same issue.

Here are the errors I am receiving:


IE7,IE8 - Open Workbench
------------------
java.lang.RuntimeException: Failed to load the configuration for LanguageCode
at com.kintana.core.gui.LogonApplet.setLocale(LogonApplet.java:553)
at com.kintana.core.gui.WorkbenchApplet.init(WorkbenchApplet.java:95)
at sun.applet.AppletPanel.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: Failed to load the configuration for LanguageCode
at com.kintana.core.gui.LogonApplet.setLocale(LogonApplet.java:550)
... 3 more

IE7,IE8 - Open Workbench (desktop)

After successful download, the splash screen will display for a few seconds then dissapear. Nothing else happens (except java processes slowly building up upon multiple tries).


Firefox - Open workbench
----------------------------
Connection not established. Please close this window, refresh your Dashboard, and try again. (KNTA-10976)

I appreciate any help/feedback anyone can offer. Thanks in advance.
9 REPLIES
Mahen M
Honored Contributor

Re: PPM Workbench Error

Having the same problem. Below is the advice I got.

Workbench should be available to everyone if they have the correct license and access grants. Users should update the following file:
C:\WINDOWS\system32\drivers\etc\hosts
With the entry
IP_Address SERVER NAME

Because there is a new version of java, wb is trying to install some items ... the users might need to have admin rights granted to make it through that process.

I have done all the above still cannot open the Workbench..... Check up whether it works for you.

Regards,
Mahendran M
michael.gregory
Esteemed Contributor

Re: PPM Workbench Error

Thanks for the response, still no change though.

I have admin rights and we are only using the OOTB admin user at the moment (as its a test/evaluation instance). This user definetly has the correct licenses, I can open the workbench as this user from another computer however it is still buggy (menus not displayed correctly, overlapping text, etc).

I tried adding the line into my hosts file, no change. I have to start believing this is an issue with PPM itself, not the workstation. I have removed all java related software and allowed PPM to install its preferred version (several times now) but still no change.
Mahen M
Honored Contributor

Re: PPM Workbench Error

What version of JRE you are having? I upgraded to 1.6.17 then I can open the WB.

Regards,
Mahendran M
Erik Cole
Honored Contributor

Re: PPM Workbench Error

Hi Michael,

When you say you can open the WB from 'another computer' do you mean a computer other than the PPM server?

You might want to try a telnet session from your workstation to the server, using the RMI (workbench) port number. If you get a 'could not open connection' type error there, you have a firewall/network issue connecting to that port...
michael.gregory
Esteemed Contributor

Re: PPM Workbench Error

Thankyou again for your responses.

Mahen - on your suggestion I tried installing 1.6.0_17 but got the same LanguageCode error.

Erik - Yes, I mean from a computer other than the PPM server. I was able to establish a connection using telnet from my workstation to the RMI port (1099) on the PPM server. This was verified by netstat on both machines.

I have opened a support ticket to try get some further help - I will post a solution here if I find one.

Cheers,
Michael
Mike Galvin
Acclaimed Contributor
Solution

Re: PPM Workbench Error

FYI- I just had this error after setting up a clustered 8.0 instance on a Red Hat server. My problem was my BASE_URL was wrong in server.conf. For our installation, we are connecting on port 10443. I forgot to add the port to the end of the BASE_URL. You may not be using high ports, but any typo in that line could cause this issue.

In our case:
Bad parameter...
com.kintana.core.server.BASE_URL=https://my.domain.com/
Good parameter...
com.kintana.core.server.BASE_URL=https://my.domain.com:10443/
Jussi-Kristian
Super Collector

Re: PPM Workbench Error

Any updates to this? We are facing the same problem after fresh PPM 8.0 installation. Tried with different JRE versions and with modifying server.conf -> no change.
michael.gregory
Esteemed Contributor

Re: PPM Workbench Error

Thanks Mike! The Base_Url was the problem. I had it set to an address that was accessible from other workstations within the domain, however it wasn't a full domain name. Entering the full domain name resolved the issue.
Ibrahimu
Acclaimed Contributor

Re: PPM Workbench Error

Hi guys...

i had a problem when try to open the open workbench in my computer its fal and show the error about "JAVA 1.5 JRE (1)"..

please help me on how can i correct the error

//Add this to "OnDomLoad" event