Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

PPM Login Page Performance Issues

Highlighted
pepdwill
Senior Member

PPM Login Page Performance Issues

Hi,

We have been experiencing slow performance specific to users logging into PPM (20-30+ seconds) and I am trying to learn more about what is causing this; specifically I  was hoping to understand more about what PPM is doing behind the scenes during a logon event.  What data does PPM prefetch during the login event?  Is it just data for the default dashboard page portlets, or is it more than that?  

 

 

I also see the following error message in the log, does anyone know what this might indicate, or whether this could be tied to the performance issue?

 

Processor19:com.mercury.itg.core.persistency.PPMOracleHibernateBatcher:2013/03/21-20:20:28.816 CDT: Exception executing batch:

org.hibernate.StaleStateException: Batch update returned unexpected row count from update; actual row count: 0; expected: 1

for SQL: update ppm_server_instance set version=?, server_name=?, status_id=?, start_time=?, end_time=?, url_base=?, available_light_listeners=?, available_heavy_listeners=?, created_by=?, creation_date=?, last_updated_by=?, last_update_date=? where id=? and version=?

 

 

Thanks!

 

Danny

4 REPLIES
Etienne_Canaud
HPE Expert

Re: PPM Login Page Performance Issues

Hi Danny,

 

There is a very small chance that this may be caused by some huge security group that takes time to be cached on Login, however, the most likely culprit is the dashboard landing page.

 

You can easily find out whether this dashboard page is the culprit:

1) Is it also long to refresh this dashboard page once you are logged in?

2) If you change the dashboard default page to be an empty page, do you still experience long login times?

 

I know that many PPM admins are following the performance good practice to have a super-leightweight Dashboard default page.

 

Kind Regards,

Etienne.

pepdwill
Senior Member

Re: PPM Login Page Performance Issues

Thanks Etienne,

 

Interesting about the security group being a possible culprit.  We do have a default group that all users belong to, and perhaps that could be a root cause?  Once logged in, the portlets only take a few seconds at most to refresh.

 

Do you think it would be the security group caching?  Is there a way to know for sure?

 

Thanks,

Danny

Etienne_Canaud
HPE Expert

Re: PPM Login Page Performance Issues

Hi Danny,

 

 

I don't think that having all users in one single security group will impact the logging action. It did impact the create/edit timesheet on PPM 7.5 but was fixed long time ago. You can try to login with a user having a single dedicately created security group, however I doubt it's the cause of the problem.

 

What version of PPM are you using?

And did you noticed performance degradation after an upgrade?

 

 

pepdwill
Senior Member

Re: PPM Login Page Performance Issues

We enabled some detailed logging and signs are pointing to the issue likely being network related, rather than being a database issue.  Thank for your help!

//Add this to "OnDomLoad" event