The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

PPM 9.14: IIS stops running and not responding even restarted

Highlighted
chonacaraan
Occasional Contributor

PPM 9.14: IIS stops running and not responding even restarted

Background:

The system architecture is
1 - DB Server (Oracle)
1 - Application Server (PPM)
1 - Web Server (IIS)

 

PPM server is up and running using the direct URL (IP and Port) but using the link that uses IIS it is not and we encounter error 500.

 

It happens once in a while in our environment and we want to know the root cause of this problem. I can't see any error in server log that would link on this issue. In IIS log, that we are not familiar with, we always encounter: "(HPPPM) can't receive the response message from tomcat, network problems or tomcat" errors then at some point it won't recover the connection anymore then that is the time the IIS will stops running. Isapi log was attached.

 

The workaround is to restart PPM service to refresh the ports to be able to make it work.

 

Any thoughs?

 

Thanks,

Chona

2 REPLIES
gtg732w
Occasional Contributor

Re: PPM 9.14: IIS stops running and not responding even restarted

Chona,

When this happens, what are you seeing on the PPM side? If you look at processor/memory/disk utilization, is PPM running out of resources?

Typically this is seen if PPM is running out of resources and is unable to process incoming connections, or possibly if old connections to PPM are never closing from the web server and IIS cannot create any additional connections.

One other thing that can happen: if the server is virtual and is VMotioned to a new underlying physical host, and if IIS does not have network access to the new underlying physical host, you can run into similar situations. This is less likely, but a possibility.

If you can let us know what PPM looks like when you're running into the issue, we should be able to provide some more guidance.

Thanks,
Dan
chonacaraan
Occasional Contributor

Re: PPM 9.14: IIS stops running and not responding even restarted

I can't see any logs on PPM side. How do we know that there's a lot of old connections to PPM are never closing from the web server?

//Add this to "OnDomLoad" event