Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

PPM 9.1 Install Error

Highlighted
Rahul Chourey
Acclaimed Contributor

PPM 9.1 Install Error

PPM 9.1 Install failed.
Below are some of the lines of the log file:

INFO 2011-05-18 14:38:44 CheemaRunner: Completing the database creation...
INFO 2011-05-18 14:38:44 CheemaRunner: action=RecompileInvalid, file=D:\PPM91_Install_Bundle\ppm910\xml\recompile.xml
INFO 2011-05-18 14:38:44 CheemaRunner: log file=D:\PPM91\install_910\logs\DB\recompile.log
ERROR 2011-05-18 14:39:57 CheemaRunner: Exception happened: D:\PPM91_Install_Bundle\ppm910\xml\recompile.xml:75: The following error occurred while executing this line:
D:\PPM91_Install_Bundle\ppm910\xml\recompile.xml:89: exec returned: 4
com.kintana.ia.common.cheema.ItgCheema.start(ItgCheema.java:333)
com.kintana.ia.common.actions.CheemaRunner.install(CheemaRunner.java:126)
com.zerog.ia.installer.actions.CustomAction.installSelf(DashoA10*..)
ZeroGaei.run(DashoA10*..)

INFO 2011-05-18 14:39:57 CheemaRunner: Set the installer's status to FAILED
INFO 2011-05-18 14:39:57 CheemaRunner: install end

Any suggestion?

Thanks and Regards
Rahul
13 REPLIES
cmdv
Occasional Contributor

Re: PPM 9.1 Install Error

I have the same error.... any solutions?

 

Thanks in advanced.

 

Carlos

cmdv
Occasional Contributor

Re: PPM 9.1 Install Error

To solve this problem (from HP support):

 

Modify line 88 and line 90 in the <PPM_Extract>\ppm910\xml\recompile.xml, whenever you see

-i18n none

on line 88 and 90, change them to

-i18n charset

then save this file.

Re-run the install and choose continue.

 

I reinstall ppm 9.10 with this workaround and works fine.

 

Regards,

 

Carlos

ShivSankaran
Acclaimed Contributor

Re: PPM 9.1 Install Error

Hi,

 

We are facing a similar error and the fix did not help.

 

Below is our error

 

INFO 2011-09-09 10:52:55 CheemaRunner: Creating database packages in the RML schema...
INFO 2011-09-09 10:52:55 CheemaRunner: action=rml_before, file=/opt/ppmcpoc/PPM_Installer/ppm910/xml/rml_before.xml
INFO 2011-09-09 10:52:55 CheemaRunner: log file=/opt/ppmcpoc/install_910/logs/DB/RML/rmlPackages.log
ERROR 2011-09-09 10:52:56 CheemaRunner: Exception happened: null
com.kintana.ia.common.cheema.UpgException.printStackTrace(UpgException.java:53)
com.kintana.ia.common.cheema.ItgCheema.start(ItgCheema.java:312)
com.kintana.ia.common.actions.CheemaRunner.install(CheemaRunner.java:126)
com.zerog.ia.installer.actions.CustomAction.installSelf(DashoA10*..)
com.zerog.ia.installer.AAMgrBase.a(DashoA10*..)
com.zerog.ia.installer.ConsoleBasedAAMgr.a(DashoA10*..)
com.zerog.ia.installer.AAMgrBase.e(DashoA10*..)
com.zerog.ia.installer.AAMgrBase.n(DashoA10*..)
com.zerog.ia.installer.ConsoleBasedAAMgr.a(DashoA10*..)
com.zerog.ia.installer.AAMgrBase.e(DashoA10*..)
com.zerog.ia.installer.AAMgrBase.n(DashoA10*..)
com.zerog.ia.installer.Co

John_R_PPM
Acclaimed Contributor

Re: PPM 9.1 Install Error

I am also getting this error and will attempt the workaround has anyone else found a solution? Thanks.

John_R_PPM
Acclaimed Contributor

Re: PPM 9.1 Install Error

I tried the workaround and that looks like it allowed me to complete the install with minor errors on install... I will apply the patch now

Alex Camargo [P
Acclaimed Contributor

Re: PPM 9.1 Install Error

Im having the same problem Raul.

 

I performed the changes in the XML file and does not solve the problem.

 

Can anyone help me?? Please it is urgent.

 

Thanks very much.

 

Best Regards.

 

Alex Camargo

 

 

 

 

d4y4n4
Frequent Visitor

Re: PPM 9.1 Install Error

Hi,

Please make sure that you installed a supported java version for PPM 9.1.
Did you install cygwin?

BTW, you should run install.sh to install PPM on Window. Please refer to the installation guide.

Regards,
Dayana
d4y4n4
Frequent Visitor

Re: PPM 9.1 Install Error

Hi,

I found a solution for the other error

Installing HP PPM 9.10 on windows, the following was observed:

Everything seems to be ok until the last steps. Just before the completion of the installation process, the following message was shown:

"Install failed with the message below, please exit the installation now.
Completing the database creation...".

Error in the installation log file:

ERROR 2012-04-26 09:19:37 CheemaRunner: Exception happened: java.sql.SQLException: ORA-01403: no data found
ORA-06512: at line 50

When existing the installation and starting the server there is no problem. The server starts. But when trying to connect as admin, the error log starts with the following lines:

JSESSIONID=D6640C27DC6FD51B230C36EE232BB3A0.HPPPMBTO,USERNAME= server:http-0.0.0
.0-8080-Processor24:com.kintana.core.server.servlet:2011/09/15-17:05:48.307 EEST
: cannot execute PM Logon
JSESSIONID=D6640C27DC6FD51B230C36EE232BB3A0.HPPPMBTO,USERNAME= server:http-0.0.0
.0-8080-Processor24:SystemErr:2011/09/15-17:05:48.313 EEST:


JSESSIONID=D6640C27DC6FD51B230C36EE232BB3A0.HPPPMBTO,USERNAME= server:http-0.0.0
.0-8080-Processor24:SystemErr:2011/09/15-17:05:48.325 EEST: com.mercury.itg.exce
ptions.InfrastructureException: unable to return region for user Admin User

Exception Correlation: GUID=5E846B4B-C074-EA9B-D511-4E98C460F47E
Generated Time=2011/09/15-17:05:48.305 EEST
Server Node Name: HPPPMBTO
JSESSIONID=D6640C27DC6FD51B230C36EE232BB3A0.HPPPMBTO,USERNAME= server:http-0.0.0
.0-8080-Processor24:SystemErr:2011/09/15-17:05:48.336 EEST: at com.mercury.i
tg.core.user.impl.UserImpl.getRegion(UserImpl.java:336)
Filtered Out x Stack Trace Lines.



Cause


Investigations showed that there were no currency and thus also no base currency enabled. While it is not possible to use a fantasy-abbreviation for a region during the use of the install wizard, in this case a new region code should have been used that was changed between versions. The region used was Turkey for this case. Old code before: TRL. New code now: TRY

This left the table KCST_CURRENCIES without any currency enabled, no base currency was shown either.

Fix

Enable one language as a first step – take the Brazilian Real as an example:

1) Check table KCST_CURRENCIES and note the ID of the currency that is needed and the one that needs to be enabled. In our example we went to enable the BRL.
BRL : CURRENCY_ID = 13

2) Run the following query to enable the Brazilian Real as Currency:
UPDATE KCST_CURRENCIES SET ENABLED_FLAG = 'Y' WHERE CURRENCY_CODE = ‘BRL’;

3) Run the following query to ‘activate’ the Brazilian Real as Base Currency:
UPDATE KCST_CURRENCIES SET BASE_CURRENCY_FLAG = 'Y' WHERE CURRENCY_CODE = ‘BRL’;

4) If any other currencies need to be enabled, set to Y for ENABLED_FLAG appropriately as in step 2)

However, we then also need to set the base currency in at LEAST this other place:

5) UPDATE KNTA_SERVER_PARAMETERS set value = 13 where description = ‘System Base Currency ID’;

6) Commit;

Last parameter and value of course also dependent on the currency chosen as base in step 3.
Whichever base currency is checked therefore, choose the value for that in the table KCST_CURRENCIES.

BE AWARE that after you have set this currency and you have financial data in the database, you will NEVER AGAIN be able to change this value otherwise you’ll corrupt the financial data for the whole application. EVERYTHING is stored in base currency and if you change that after having worked with the instance, everything will corrupt in respect to that financial data.

Regards,
Dayana


jaybglg
Occasional Contributor

Re: PPM 9.1 Install Error

thanks Carlos.  your solution worked for me.

 

thanks

jay

 

feds619
Acclaimed Contributor

Re: PPM 9.1 Install Error

HI,

Im trying to integrate PPM to ALM ..

The problem is that i am stack in running the "ppm-910-ALM.jar"

do anyone know where to find that file??

 

Thanks in advance!

md1738
Acclaimed Contributor

Re: PPM 9.1 Install Error

Hi Carlos,

 

Your solution kind of work for me with the following error.

"At least one service or driver failed during system start up. Use the event viewer to examine the event log for details".

 

I would appreciate if you can provide a little explanation for the solution you came up with. Also, can you tell me if there are any implications of the above error that you have found later while using the application.

 

Thanks in advance.

 

Regards,

Malay

ClaudiuM
Acclaimed Contributor

Re: PPM 9.1 Install Error

Carlos,

 

Your solution worked just fine.

 

Good stuff.

 

Thanks

SamuTheSecond
Acclaimed Contributor

Re: PPM 9.1 Install Error

Hmm,zillion  thanks, Same install error is present on 9.3 as well now on year 2015.

 

Still fixed by changing "i18n none" to "i18n charset".

 

 

//Add this to "OnDomLoad" event