Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

PPM 8.0 upgrade failed

Highlighted
Shravan Kathuri
Senior Member

PPM 8.0 upgrade failed

Hi

After we have upgraded to PPM 8.0, we are unable to start the server. Canany one tell me what could be the problem?

I have attached the serverlog.Quick response would be appreiciated.

Thanks
Shravan Kumar.K
17 REPLIES
Sascha Mohr
Esteemed Contributor

Re: PPM 8.0 upgrade failed

Hi,
did you already check that none of the ports used for clustering is blocked? The cluster mechanism in 8.x is different from the one in earlier versions (uses more ports for communication too).
Regards
Sascha
koya
Regular Collector

Re: PPM 8.0 upgrade failed

Can you attach the serverLog.

Shravan Kathuri
Senior Member

Re: PPM 8.0 upgrade failed

I have already attached the serverlog file. Please can anyone help me. we are stuck in the upgrade process.

Thanks
Shravan Kumar.K
Sascha Mohr
Esteemed Contributor

Re: PPM 8.0 upgrade failed

In the log you attached it said:
Failed to connect to server 3.57.28.26:1100 [Root exception is java.net.ConnectException: Connection refused]]]

i would start with the port config in server.conf.
Daniel Galvez
Collector

Re: PPM 8.0 upgrade failed

Hi Shravan,

Did you see the file /opt/ITG/server/server1/deploy/cluster-service.xml it appears that has an invalid character ":" in value part of property....

Let me know if it helps...
Kind regards,
Daniel
Vibhor Dwivedi
Regular Collector

Re: PPM 8.0 upgrade failed

Hi shravan,

on last line of log

some where it is picking up value for jboss service as

jboss:service=https://dev-tg.health.com/;

and indicating Invalid character ':' in value part of property

may be it will due to this property.


sirib9
Regular Collector

Re: PPM 8.0 upgrade failed

Hi Shravan,

You can try removing colon if you have any in multicast_name parameter value in server.conf file.

Thanks
Shravan Kathuri
Senior Member

Re: PPM 8.0 upgrade failed

Hi All,

We are able to start the PPM server. We have changed the command for startup of the server to resolve the ":" property error. Now we are able to start the server. But when we open the dashboard, we the dashboard portlets are not displaying properly.

I have attached the screenshot for this. Can anyone had faced the same problem. If so, what is the resolution.

Thanks,
Shravan.K
Shravan Kathuri
Senior Member

Re: PPM 8.0 upgrade failed

Is anyone has any resolution for my dashboard problem?
KChauhan
Super Collector

Re: PPM 8.0 upgrade failed

Hi Shravan,

We are also facing the same issue after upgrade to 7.5.After we restart the server after upgrade,first of all it did not start throwing the jboss exceptions at itg.war/web.xml dir.so we tried a workaround and it started but the portlets/module page/portlet defn. page showed abruptly as attached.Also the other links like create request/report works fine.

How was the issue resolved in case it has?let me know the same.

Thanks,
Kushal
Shravan Kathuri
Senior Member

Re: PPM 8.0 upgrade failed

Hi kushal,

Check the below settings exists or not in obj.conf file of your webserver.

NameTrans fn="assign-name" from="/itg/*" name="servlet"
NameTrans fn="assign-name" from="/dashboard/*" name="servlet"

we have resolved this issue by adding above parameters to obj.conf file.But not sure whether those will work in IE 6 or not. We have IE7

Thanks
Shravan
KChauhan
Super Collector

Re: PPM 8.0 upgrade failed

Hi,

Thanks for the response. U mean to say the PPM application server directories for the obj.conf or the Apache webserver dir. maintained in PPM.
Shravan Kathuri
Senior Member

Re: PPM 8.0 upgrade failed

It is related to webserver.
KChauhan
Super Collector

Re: PPM 8.0 upgrade failed

Ok. do you know the path where the obj.conf file is locate din webserver.
Shravan Kathuri
Senior Member

Re: PPM 8.0 upgrade failed

the base path may change from users to users. There will be folder like /config/obj.conf
KChauhan
Super Collector

Re: PPM 8.0 upgrade failed

Which webserver do u have ..IIS or Apache?

Mine is Apache..had u faced this issue in case yours is IIS..
Cesar Roque
Regular Collector

Re: PPM 8.0 upgrade failed

Hi KChauhan

How exactly did you solve it ? I have some problems starting my instance like yours.

Thanks
//Add this to "OnDomLoad" event