Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

PPM 7.5 SP7 Upgrade Problem

SOLVED
Go to solution
Highlighted
Akif Saburi
Regular Collector

PPM 7.5 SP7 Upgrade Problem

Hi,

We have PPM 7.5 currently. We are trying to upgrade to PPM 8.0. But before that I was recommended by HP to upgrade to PPM 7.5 SP7. While installing the patch, I'm getting the following error. I'm not aware what needs to be done. Kindly advise.

Steps followed:

1. Stopped the PPM Server
2. Used the jar file for running the patch
3. Ran the below command and got the error

$ sh kDeploy.sh -i SP7
JAVA_HOME = /usr/jdk/jdk1.5.0_18
java version "1.5.0_18"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_18-b02)
Java HotSpot(TM) Server VM (build 1.5.0_18-b02, mixed mode)
kDeploy.sh: stty: not found

Please enter the DB password for knta:
xxxxx
kDeploy.sh: stty: not found

Extracting patch files
Checking deployment phases

+++
+++ Pre install validations
+++

Check for Service Pack pre-requisites

-->Pre-requisites check complete.


+++
+++ Applying Filesystem Changes
+++
Extracting fs_home.jar (/apps/chainl)
Extracting fs_war.jar (/apps/chainl/server/Kintana/deploy/itg.war)
Extracting fs_multiserv.jar (/apps/chainl/server/Kintana)
Deleting obsolete SDI files

+++
+++ Applying Database Changes
+++
Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version
umber in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:1
4)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
ERROR:

2 REPLIES
Utkarsh_Mishra
Honored Contributor
Solution

Re: PPM 7.5 SP7 Upgrade Problem

Hi Akif,

 

The issue is due to OLD java version (1.5.0_18), try to upgrade it to Java Platform Standard Edition 6 Development Kit (JDK) 1.6.0 (32-bit only)(available from Oracle).

 

As per the compatability matix Java version 1.5.x is not supported for PPM 7.5.

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
Akif Saburi
Regular Collector

Re: PPM 7.5 SP7 Upgrade Problem

Thanks a ton.  It worked after upgrading JDK to 1.6.0.  i was so stupid not to notice that.

//Add this to "OnDomLoad" event