Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

PPM 7.1 SP5 loosing database connection every now and then

Highlighted
Jussi-Kristian
Super Collector

PPM 7.1 SP5 loosing database connection every now and then

Our production environment is loosing database connection once in 2-4 weeks. Its usually happening to one cluster only and to both randomly. We are running it on SUN Solaris and Oracle 10.

Is anyone having same kind of a problems?

Error message says:

server:FX Rate Update Service:SystemOut:2008/05/31-01:03:01.740 EEST: The database could not be reached. (KNTA-10224) server:FX Rate Update Service:SystemOut:2008/05/31-01:03:01.740 EEST: The database could not be reached. (KNTA-10224) server:FX Rate Update Service:SystemOut:2008/05/31-01:03:01.741 EEST: nested detail:java.sql.SQLException: No connections were available after waiting 180 seconds server:Notification Service:com.kintana.core.notifications:2008/05/31-01:06:01.902 EEST: The database could not be reached. (KNTA-10224) nested detail:java.sql.SQLException: No connections were available after waiting 180 seconds

server:Exception Rule Service:SystemOut:2008/05/31-01:06:01.974 EEST: An HP internal error has occurred. Please contact HP Project and Portfolio Management support if the problem persists. (KNTA-10023) server:Exception Rule Service:SystemOut:2008/05/31-01:06:01.974 EEST: nested detail:The database could not be reached. (KNTA-10224) The database could not be reached. (KNTA-10224) nested detail:java.sql.SQLException: No connections were available after waiting 180 seconds
10 REPLIES
Sue Britton
Acclaimed Contributor

Re: PPM 7.1 SP5 loosing database connection every now and then

We have just started having this problem in a development environment. Where you able to solve the problem? -Thanks
Erik Cole
Honored Contributor

Re: PPM 7.1 SP5 loosing database connection every now and then

You might look at your Broker Performance Report in the workbench and see how many connections are in use and/or free. We experienced a case where running a report (specifically, the PMO - Project Status Report) and the report was not releasing connections. We added a tag to the report's jsp and it solved it.

Also, it could be that the DB goes down for cold backup, etc.
Jyotir ++
Member

Re: PPM 7.1 SP5 loosing database connection every now and then

Hi,

Please check that on database server there is no spying process running.it may be taking db down.

In addtion to this please there is no scheduled job for taking database back-up.

Make sure you always flush db connection when ever you are creating database connection by any way like Custom report or in executionsteps.

Hope this will help you.


Regards,
Jyotir
PPM Admin
Regular Collector

Re: PPM 7.1 SP5 loosing database connection every now and then

Hi,

What is the spying process you are refering to? Can you give any sample? And the scheduled job for taking database back-up, are you refering the daily database backup in the server?

Thanks.

Jyotir ++
Member

Re: PPM 7.1 SP5 loosing database connection every now and then

Hi,

Spying process are like any background process which may be doing some maintenance activties due to which its stoping DB services.

Please try to delete/rename your Tmp/work folder as well.Some time it helps.

clear all inactive session.

Hope this will help you.
Carlos Thompson
Regular Collector

Re: PPM 7.1 SP5 loosing database connection every now and then

Jussi-Kristian,

I searched for KNTA-10224 and found this thread. We are having the exact same problem, it only happens maybe once or twice a month.

Did you ever find resolution?

Thanks
Carlos
Niraj Prabhu
Frequent Visitor

Re: PPM 7.1 SP5 loosing database connection every now and then

Carlos,

All above questions are applied to you as well. If the author has not found the solution yet, then can you please find the answers for what Jyotir asked in the beginning. May be we can try to proceed on this issue.

Thanks!
Niraj
Niraj P.
Jussi-Kristian
Super Collector

Re: PPM 7.1 SP5 loosing database connection every now and then

Hi,

I think that this problem has gone away. We did however have reports taken directly from the database. We never really identified that was it causing the problem but we've now changed the reporting solution a bit so that might have been the reason.
DIP_2
Super Collector

Re: PPM 7.1 SP5 loosing database connection every now and then

We are also facing the similar incident where the ppm application becomes unavailable during certain part of the day.It comes up on its own. i found you got the solution if you could share with me what have you done in details.

Kari Sweeney
Super Collector

Re: PPM 7.1 SP5 loosing database connection every now and then

Erik,

Can you please clarify what to look for in the Broker Connection Report? We are having similar issues, and performance is terrible. We found today after a performance test that there seem to be a lot of user locks in the DB accounting for a lot of wait time. After finding several posts out here referencing the Broker Connection Report, I tried running it, but I'm not sure what I'm looking at.

The report output has 4 sections (2 for each user node, and 2 for our 2 services-only nodes), and in the user1 node section, there are 4 connections. Our other user node doesn't show any connections.

What kind of output should I be looking for?

thanks,
-Kari
//Add this to "OnDomLoad" event