The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday 7:30am (PST)
Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Object Migrator 7.5 - Migration problem

Highlighted
dgsagir2
Occasional Contributor

Object Migrator 7.5 - Migration problem

Hi,

 

We want to make PPM 9.13 compatible with Oracle EBS 11i (11.5.10.2) and R12. To do this, we migrated Object Migrator from version 6.0 to 7.5. Following this migration, it is no longer possible to migrate Concurrent Programs on EBS 11i (see attachments). Everything else works.

Does anyone have faced the same type of issue?

 

Thanks,

14 REPLIES
Raj Ghimire
Occasional Visitor

Re: Object Migrator 7.5 - Migration problem

We went through Obj Mig 6.0 to 7.5 Upgrade last year as well but we never noticed this "MSG-00001: LOAD (1005):ORA-00904: "FCP"."MULTI_ORG_CATEGORY": invalid identifier"  Error in our case.

 

Are you sure you are still doing migration between 11i  instances?  

This looks lto me lot like R12 kind of error which seems to pop up all over the web searches.

 

If you are still doing 11i migration, You might also want to double check the "Oralce Apps Version" value that you have in the Extension Data tab of the Environment in the workbench. Just make sure it is still R11 and not R12.

 

Here is one R12 related info I see on the web.  You mgith want to check it out.......Simply search for the error message this shows up everywhere for R12.

New column MULTI_ORG_CATEGORY in FND_CONCURRENT_PROGRAMS
• Values ‘S’ = Single Org
– ‘M’ = Multi Org
• In upgrade, for programs where definition has been Copyright 2010 Solution Beacon, LLC All Rights Reserved Any other commercial product names herein are trademark, registered trademarks or service marks of their respective owners. 33 customized, value is null and concurrent program will NOT
run.
• Script to set value
– UPDATE FND_CONCURRENT_PROGRAMS
SET MULTI_ORG_CATEGORY = {'S‘ or ‘M’}
WHERE CONCURRENT_PROGRAM_NAME = '{Program Name}'

 

Also, probably not related  but I think PPM 9.12 had PPMC9.10 OraAppsExt Patch as well. No harm in double checking.

 

Thanks.

-Raj

dgsagir2
Occasional Contributor

Re: Object Migrator 7.5 - Migration problem

>Are you sure you are still doing migration between 11i  instances?  

 

Yes, we only have 11i instances by now, no R12. We want to prepare PPM to be able to migrate R12 instances too.

 

>You might also want to double check the "Oralce Apps Version" value that you have in the Extension Data tab of the Environment in the workbench.

 

Is still R11.

 

>Here is one R12 related info I see on the web.  You mgith want to check it out.......Simply search for the error message this shows up everywhere for R12.

 

MULTI_ORG_CATEGORY is a new column in R12. I don't know why is looking for it when doing Program Concurrent migration with 11i instances.

 

>Also, probably not related  but I think PPM 9.12 had PPMC9.10 OraAppsExt Patch as well.

 

Installed Extensions:

Oracle Applications Version 9.1.2

Oracle Technology Verion 9.1.0

 

When we copy the new CLMRMCP1.rdf file (the one in the 7.5 upgrade package), in the

$CLM_TOP/reports/US/ and we try to doing a migration, it's not working (log.txt).

 

But when we use the old/original CLMRMCP1.rdf file, the migration works perfectly.

 

Thanks for your help!

 

Raj Ghimire
Occasional Visitor

Re: Object Migrator 7.5 - Migration problem

Hum .. interesting...

 

I hope during 9.1 upgrade you did apply the  HP Deployment Management Extension for Oracle E-Business Suite version 9.10 ("ppm-910-OracleApps.jar") first, before applying "ppm-910-OracleApps912.jar" patch because the second one is only patch for R12 compatibility. First one would provide 9.1 files for R11.

During 9.1 Upgrade, I think you are supposed to apply these in  In  given ORDER :

 - ppm-910-OracleApps.jar

 - ppm-910-OracleApps912.jar

 

I lost the link but please check the patch information page titled "PPM Center 9.10 Oracle Apps Extension" which provides info in detail.

 

And importantly, You might want to double check with HP Support to make sure you are on the right path.

 

Thanks.

-Raj

dgsagir2
Occasional Contributor

Re: Object Migrator 7.5 - Migration problem

Thanks for your replies Raj

 

Do you know if we have to, in order:

 

#1 Migrate OM from 6 to 7.5

#2 ppm-910-OracleApps.jar

#3 ppm-910-OracleApps912.jar

 

Because we did:

 

#1 ppm-910-OracleApps.jar

#2 ppm-910-OracleApps912.jar

#3 Migrate OM from 6 to 7.5

 

 

Also, since you migrate OM to 7.5, are you still able to migrate Program concurrent with 11i and r12 instances?

Raj Ghimire
Occasional Visitor

Re: Object Migrator 7.5 - Migration problem

Yes, as per HP recommendation, Object Migrator 7.5 needs to get installeld first before applying 9.1 version of oracle extensions because of compatibility issues. This is the recommended path:

 

  • HP Object Migrator version 7.5
  • PPM Center version 9.1x
  • HP Deployment Management Extension for Oracle E-Business Suite version 9.10 (ppm-910-OracleApps.jar)
  • HP Deployment Management Extension for Oracle E-Business Suite patch for R12 compatibility (ppm-910-OracleApps912.jar)

 

So, for your case, I would think simple reinstallation of the oracle extensiongs in proper order should fix things BUT Please contact HP Support and and confirm before proceeding. And don't get held up on first level supoprt and try to reach the senior experts as very few Support techs have much knowledge on Deployment mgmt front.

 

IN our case, No issues on R11 migration front.

Our plans for R12 slowed down a bit so haven't tested R12 myself, but as long as you define the OracleApps Version in the Extension data tab of the particular environment correctly, I would think it should work just fine as there are two separate sets of CLM files(e.g. FND Commands) for R11 and R12 available after the 912 patch. the only difference being which set of file Object Migrator would use, which would be controlled by Oracle Apps Version value defined.

 

Good Luck !

-Raj

dgsagir2
Occasional Contributor

Re: Object Migrator 7.5 - Migration problem

We did the recommended path but we have the same problem...

keshribalaram
Acclaimed Contributor

Re: Object Migrator 7.5 - Migration problem

Hi,

We are implementing Object Migrator with Oracle applications release R12.1.3.

Please let me know where to get detail integration steps and softwares for this implementation.

Thanks,
-Bala
dgsagir2
Occasional Contributor

Re: Object Migrator 7.5 - Migration problem

Hi keshribalaram,

 

I think you will have to contact HP to get the software.

 

Have a nice day,

Jason Nichols K
Honored Contributor

Re: Object Migrator 7.5 - Migration problem

I'm working on a new installation for a client, using PPM 9.14 and we're seeing this same error. It's a clean install of the 7.5 Object Migrator on a completely separate and clean OA server. The Oracle Apps Extension with the 9.12 patch were applied in the correct order and verified via kDeploy.sh -l.

 

All of the Oracle Apps environments here are R11 and they are properly configured as such in PPM. For testing purposes, one of the DB Developers dropped the view in question and rebuilt it with the missing column and the code worked fine. The problem I have is that everything I've seen on the web indicates that the base column was added in R12, but it's clearly there in an R11 instance. However, what's also bothersome is that if it is supposed to be an R12 only column, why is the PPM OM trying to select it for an R11 Oracle environment?

dgsagir2
Occasional Contributor

Re: Object Migrator 7.5 - Migration problem

Hi Jason,

 

FYI, we didn't find an answer to this question. We still using OM 6.0 with PPM 9.14 and Oracle Apps Extension 9.12 on R11 only.

 

Let me know if you find it...

Jason Nichols K
Honored Contributor

Re: Object Migrator 7.5 - Migration problem

MY DB team doesn't want to use the old version as we don't know what else was added to the new version. They've opened an SR with Oracle to see why that column is reported to be a new column with R12 but is included in the R11 schema. With the test that we did, the addition of the missing column to the view that the PPM Conc Prog uses allowed it to successfully migrate a Conc Prog from one enviroment to the next.
Ryan Proctor HP
HPE Expert

Re: Object Migrator 7.5 - Migration problem

Hi Jason,

 

Did you hear anything back from Oracle about why the column is in the R11 schema? 

 

I'm guessing it was included in some R11 patch.  Do you happen to know when/where or what patch it was added in R11?


Regards,
Ryan

 

Jason Nichols K
Honored Contributor

Re: Object Migrator 7.5 - Migration problem

The response Oracle gave back to the DBA team was the PPM wasn't supported and didn't give any further information. I don't know when/which patch introduced this column to the base table. However, I did open a ticket with HP Support and they provided an updated version of the Conc Program for migrating Conc Progs and that took care of the issue.

Akif Saburi
Regular Collector

Re: Object Migrator 7.5 - Migration problem

We faced similar issue whil upgrading for one of my clients.  Issue here is becuase of the PPM Oracle Apps R12.1.3 you have installed.  There is not ready fix available for this.  We had to customize the rdf files which PPM uses for AOL migrations.

 

If I remeber correctly, we faced issues for Concurrent Programs & Report Set object types.

 

You have to customize the RDF files untill/unless HP comes with a hot fix.

//Add this to "OnDomLoad" event