Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Notification links requiring users to re-authenticate to PPM.

SOLVED
Go to solution
Highlighted
Heather Sprutte
Occasional Contributor

Notification links requiring users to re-authenticate to PPM.

Notification links that are sent to a user's email inbox are requiring users to re-authenticate to PPM even though they already have an open session. We are using a clustered environment, and our servers sit behind a BIGIP load balancer. Does anyone know of any settings that I have overlooked in the set up?
4 REPLIES
Jim Esler
Honored Contributor
Solution

Re: Notification links requiring users to re-authenticate to PPM.

Make sure the value set for com.kintana.core.server.BASE_URL in your server.conf file is the same URL used to connect through the load balancer.
Sascha Mohr
Esteemed Contributor

Re: Notification links requiring users to re-authenticate to PPM.

Hello Heather,
how are the links placed in the notification? Are you using tokens to create them at runtime or have you placed them manually in the notification definition?
If so, the URL must match between the link in the notification and the URL the user entered in his browser.
We had a similar situation where users entered a DNS alias (like "ppm") and later clicked on a link in a notification with an URL like http://server.domain.tld/... They had to login again.
Regards
Sascha
Heather Sprutte
Occasional Contributor

Re: Notification links requiring users to re-authenticate to PPM.

I just looked at the server.conf file and I see on WHPPPM01P that the com.kintana.core.server.BASE_URL=http://WHPPPM01P:8091/


On WHPPPM02P, the com.kintana.core.server.BASE_URL=http://WHPPPM02P:8091/

Our clustered environment information is set up as below:

# Primary Server Details (to be used by hostname WHPPPM01P)
#
# MULTICAST settings
##

com.kintana.core.server.MULTICAST_CLUSTER_NAME=PPM
com.kintana.core.server.MULTICAST_DEBUG=false
com.kintana.core.server.MULTICAST_IP=224.0.0.38
com.kintana.core.server.MULTICAST_LEASE_MILLIS=20000
com.kintana.core.server.MULTICAST_PORT=9900

#
#

com.kintana.core.server.KINTANA_SERVER_NAME=Service
com.kintana.core.server.SERVER_NAME=WHPPPM01P
com.kintana.core.server.RMI_URL=rmi://WHPPPM01P:1175/KintanaServer
com.kintana.core.server.HTTP_PORT=8091
com.kintana.core.server.BASE_LOG_DIR=//rsgeno5d/hpppmd/detachment/Logs
com.kintana.core.server.REPORT_DIR=//rsgeno5d/hpppmd/detachment/Reports
com.kintana.core.server.ATTACHMENT_DIRNAME=//rsgeno5d/hpppmd/detachment/attachments
com.kintana.core.server.TRANSFER_PATH=//rsgeno5d/hpppmd/detachment/Transfers

#
# Secondary Server Details (to be used by WHPPPM02P)
#
@node
com.kintana.core.server.KINTANA_SERVER_NAME=Service_Secondary
com.kintana.core.server.SERVER_NAME=WHPPPM02P
com.kintana.core.server.RMI_URL=rmi://WHPPPM02P:1175/KintanaServer
com.kintana.core.server.HTTP_PORT=8091

And we do have the users typing in PPM as far as the URL and accessing PPM. I checked the link in the notification and it points to a token.

With this being a clustered environment, I'm not sure what to change as far as the com.kintana.core.server.BASE_URL

Thanks!!!!!!
Heather Sprutte
Occasional Contributor

Re: Notification links requiring users to re-authenticate to PPM.

I found it!! It was the base URL. Thank you both so much.
//Add this to "OnDomLoad" event