Project and Portfolio Management Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Notification Problem.

Highlighted
eozturk
Occasional Advisor

Notification Problem.

PPM System isnt send any notification mail. 

But only we have problem  for workflow actions.For examle, when sending resource request in staffing profile,system send  notification and  resource managers recieved e-mail during sending request.

Does  anybody have idea for this issue?

Thanks

3 REPLIES
eozturk
Occasional Advisor

Re: Notification Problem.

In additions notification service hasnt been working since 18.04.2014.

I disable and then enable but system is seen "not working" on audit page 

 

skbd
Regular Collector

Re: Notification Problem.

I have run across this before and usually it seems to be something quirky internally to PPM.

I will edit the notification by adding one additional sendee (usually myself) and save everything and then the notification begins to work.

 

Its like the notification has be re-registered internally to the system.

Loc_Nguyen_PPM
Occasional Visitor

Re: Notification Problem.

Hi eozturk,

 

I found this tip and you can follow it for troubleshooting your problem.

 

How to start troubleshooting issues with notifications:

 

1. Check the serverLog.txt file for exceptions containing the words Notification or Notifications.

 

2. Check these pages to see if the needed services are enabled and working:

Open -> Administration -> View Services Audit Page

Open -> Administration -> Schedule Services

 

3. Check if there are entries in all these tables:

 

knta_notif_txn_columns

knta_notif_txn_details

knta_notif_txn_parents

knta_notif_txn_recipients

 

4. Check if triggers exist:

Select trigger_name from user_triggers where trigger_name like 'KWFL%'

 

We are interested if these 6 triggers are in the result:

 

KWFL_WORKFLOW_PARAMETERS_T1

KWFL_WORKFLOW_STEPS_T1

KWFL_STEP_TRANSACTIONS_NT1 (trigger)

KWFL_STEP_TRANSACTIONS_NT2 (trigger)

KWFL_STEP_TRANSACTIONS_NT4 (trigger)

KWFL_STEP_TRANSACTIONS_NT5 (trigger)

 

5. Add this parameter in the logging.conf file (PPM-HOME\conf folder) for debugging Notifications.

 

com.kintana.core.logging.PRODUCT_FUNCTION_LOGGING_LEVEL = com.kintana.core.notifications, DEBUG

 

Stop PPM server. Run kUpdateHtml.sh. Start the server again.

 

Wait the service to run and monitor the serverLog files for errors related to notifications.

 

Note: if you are using Sendmail on Linux, check the following file /var/admin/mail.log

 

 

Hope this help.

 

 

 

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
//Add this to "OnDomLoad" event